app-portage/diffmask: Bump to EAPI 7
authorMichał Górny <mgorny@gentoo.org>
Wed, 16 May 2018 19:09:22 +0000 (21:09 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 16 May 2018 19:11:03 +0000 (21:11 +0200)
app-portage/diffmask/diffmask-0.3.3-r4.ebuild [new file with mode: 0644]
app-portage/diffmask/diffmask-9999.ebuild

diff --git a/app-portage/diffmask/diffmask-0.3.3-r4.ebuild b/app-portage/diffmask/diffmask-0.3.3-r4.ebuild
new file mode 100644 (file)
index 0000000..80b09bc
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A utility to maintain package.unmask entries up-to-date with masks"
+HOMEPAGE="https://github.com/mgorny/diffmask/"
+SRC_URI="https://github.com/mgorny/diffmask/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+       || (
+               sys-apps/portage[${PYTHON_USEDEP}]
+               sys-apps/portage-mgorny[${PYTHON_USEDEP}]
+       )"
index 14151f6b5aba04796cd4ebee02d318fe086fa7ce..8c0f4525f829a06af0033ef3e6a2658a7b26e71f 100644 (file)
@@ -1,7 +1,7 @@
 # Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=7
 PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
 
 inherit distutils-r1 git-r3