media-fonts/khmer: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Sat, 19 Oct 2019 20:11:16 +0000 (22:11 +0200)
committerDavid Seifert <soap@gentoo.org>
Sat, 19 Oct 2019 20:11:16 +0000 (22:11 +0200)
Bug: https://bugs.gentoo.org/697304
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: David Seifert <soap@gentoo.org>
media-fonts/khmer/khmer-5.0-r1.ebuild

index 8ffa9836419d0cc13a815bb8f84afa69eafb5001..7991889184d72b4ab503ebe19a3d3a464e572cbe 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
 inherit font
 
@@ -12,26 +12,25 @@ SRC_URI="mirror://sourceforge/khmer/All_KhmerOS_${PV}.zip"
 LICENSE="LGPL-2.1"
 SLOT="0"
 KEYWORDS="amd64 x86"
-IUSE=""
 
-DEPEND="app-arch/unzip"
-RDEPEND=""
+BDEPEND="app-arch/unzip"
 
 S="${WORKDIR}/All_KhmerOS_${PV}"
+
 FONT_S="${S}"
 FONT_SUFFIX="ttf"
 
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
-       [[ -f "KhmerOS .ttf" ]] && mv "KhmerOS .ttf" "KhmerOS.ttf" # 338057
+src_prepare() {
+       default
+
+       # bug 338057
+       mv KhmerOS{\ ,}.ttf || die
 }
 
 pkg_postinst() {
        font_pkg_postinst
-       echo
+
        elog "To prefer using Khmer OS fonts, run:"
        elog
        elog "  eselect fontconfig enable 65-khmer.conf"
-       echo
 }