gnome-extra/gnome-user-share: bump to 3.32.0.1
authorMart Raudsepp <leio@gentoo.org>
Sun, 13 Oct 2019 18:23:50 +0000 (21:23 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sun, 13 Oct 2019 18:23:59 +0000 (21:23 +0300)
Package-Manager: Portage-2.3.69, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
gnome-extra/gnome-user-share/Manifest
gnome-extra/gnome-user-share/gnome-user-share-3.32.0.1.ebuild [new file with mode: 0644]

index 45150bf3b9e0d85fb15a3e2edfb628686f4364d0..caa487068302e7c86a03336425feadd3594b9daa 100644 (file)
@@ -1 +1,2 @@
 DIST gnome-user-share-3.28.0.tar.xz 393516 BLAKE2B f17efe9b763b14bb67837d65973f1125ac2bd9d49dabc359aca6fa040cb32d656d71236e306b4e97b39e49e07198aff4b3f456d62937baeff01b50d1a5ccfb67 SHA512 1b7ca604fec69402312f801d5b7117d99cb82bca674a4e4d279bda8ba9ca96c70dfd2c815d571094c1a95eb0e9084cd560445257dce194f6050d68c17ae4bb1d
+DIST gnome-user-share-3.32.0.1.tar.xz 439696 BLAKE2B 278e46adfdb2a24a2b9d8d76e38bb9a6cb1b5ee85c820fbc38aa1ebbed2481537dc8686dccef3d213c0c83bb236f1431a9706b3d6cceace78172d93798534d76 SHA512 d644aaf0c0b593188936505391b1927d883234ffa5acd6d04675575fc68409512b416d87ca6d0a7960187b433a874f2da6ec2d304eccbab8846446f89df8297e
diff --git a/gnome-extra/gnome-user-share/gnome-user-share-3.32.0.1.ebuild b/gnome-extra/gnome-user-share/gnome-user-share-3.32.0.1.ebuild
new file mode 100644 (file)
index 0000000..1b435e8
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 multilib systemd
+
+DESCRIPTION="Personal file sharing for the GNOME desktop"
+HOMEPAGE="https://git.gnome.org/browse/gnome-user-share"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+# FIXME: could libnotify be made optional ?
+# FIXME: selinux automagic support
+RDEPEND="
+       >=dev-libs/glib-2.58:2
+       >=x11-libs/gtk+-3:3
+       >=gnome-base/nautilus-3.27.90
+       media-libs/libcanberra[gtk3]
+       >=www-apache/mod_dnssd-0.6
+       >=www-servers/apache-2.2[apache2_modules_dav,apache2_modules_dav_fs,apache2_modules_authn_file,apache2_modules_auth_digest,apache2_modules_authz_groupfile]
+       >=x11-libs/libnotify-0.7:=
+       sys-apps/systemd
+"
+DEPEND="${RDEPEND}
+       app-text/docbook-xml-dtd:4.1.2
+       dev-util/itstool
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+"
+
+PATCHES=(
+       # Upstream forces to use prefork because of Fedora defaults, but
+       # that is problematic for us (bug #551012)
+       # https://bugzilla.gnome.org/show_bug.cgi?id=750525#c2
+       "${FILESDIR}"/${PN}-3.18.1-no-prefork.patch
+)
+
+src_configure() {
+       gnome2_src_configure \
+               --with-httpd=apache2 \
+               --with-modules-path=/usr/$(get_libdir)/apache2/modules/ \
+               --with-systemduserunitdir="$(systemd_get_userunitdir)"
+}