dev-lang/python: Remove static lib in 3.7.6 as well
authorMichał Górny <mgorny@gentoo.org>
Fri, 20 Dec 2019 16:11:18 +0000 (17:11 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 20 Dec 2019 16:38:16 +0000 (17:38 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-lang/python/python-3.7.6.ebuild

index 5748c1464149b840681b1d740990eb934202e9fe..26ce7fb0b0513ac54e2ec1b80ff316b8e10d480b 100644 (file)
@@ -204,6 +204,9 @@ src_install() {
 
        emake DESTDIR="${D}" altinstall
 
+       # Remove static library
+       rm "${ED}"/usr/$(get_libdir)/libpython*.a || die
+
        sed \
                -e "s/\(CONFIGURE_LDFLAGS=\).*/\1/" \
                -e "s/\(PY_LDFLAGS=\).*/\1/" \