dev-dotnet/dbus-sharp-glib: bump EAPI to 5, migrate to mono-env, add support for...
authorChristoph Mende <angelos@gentoo.org>
Fri, 18 Sep 2015 05:07:49 +0000 (07:07 +0200)
committerChristoph Mende <angelos@gentoo.org>
Fri, 18 Sep 2015 05:18:38 +0000 (07:18 +0200)
Package-Manager: portage-2.2.20.1

dev-dotnet/dbus-sharp-glib/dbus-sharp-glib-0.5.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-dotnet/dbus-sharp-glib/dbus-sharp-glib-0.5.0-r1.ebuild b/dev-dotnet/dbus-sharp-glib/dbus-sharp-glib-0.5.0-r1.ebuild
new file mode 100644 (file)
index 0000000..bcc9c7e
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools mono-env
+
+DESCRIPTION="D-Bus for .NET: GLib integration module"
+HOMEPAGE="https://github.com/mono/dbus-sharp"
+SRC_URI="mirror://github/mono/dbus-sharp/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1.0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/mono
+       >=dev-dotnet/dbus-sharp-0.7:1.0"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+pkg_setup() {
+       DOCS="AUTHORS README"
+       mono-env_pkg_setup
+}
+
+src_prepare() {
+       sed -i -e 's/gmcs/mcs/' configure.ac || die
+       eautoreconf
+}