dev-python/xlrd: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sun, 29 Mar 2020 12:07:43 +0000 (14:07 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 29 Mar 2020 12:07:43 +0000 (14:07 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/xlrd/Manifest
dev-python/xlrd/files/xlrd-0.9.3-column.patch [deleted file]
dev-python/xlrd/xlrd-0.9.4.ebuild [deleted file]

index c6f45b6489dbb4584450943705d9f93e022e1fc2..2771a9e0040ac2c7d853dab776c12322e7641c4b 100644 (file)
@@ -1,2 +1 @@
-DIST xlrd-0.9.4.tar.gz 322945 BLAKE2B cdeac4ab7c68e14d564fdd6f1da35e09a6c3a070af1111bb33e7533bdc534e05ddcb59384a72cdcbad452b26e35529431f50c2511e68422aa53f7133cfcf6141 SHA512 61d21a6b0bf5a72f75b98f6a62245fd2d0d8b091b56f31cd39e83ff0d68edba5370f81b50020f6ac52d08b0b49c0920bf44661d8501ecbde5baee7d991037a6d
 DIST xlrd-1.2.0.tar.gz 554079 BLAKE2B 57c956139a3e2239c9caeae66b36e384458f1f2060422575dcb63fb09b7f9050f669154d1479303640cc45fb5716e027d3b5d07282b08bd866c4e5366861ecef SHA512 eea14845701b86a2679f140c9730e8ee2722b4f859cdd870f86bf54df522d54fc3c78dc4354aeb958c72596a6349995e9d79935efc734de096f6e007945fc1b3
diff --git a/dev-python/xlrd/files/xlrd-0.9.3-column.patch b/dev-python/xlrd/files/xlrd-0.9.3-column.patch
deleted file mode 100644 (file)
index 0a9c274..0000000
+++ /dev/null
@@ -1,59 +0,0 @@
-From 6c2c1057d2780c079218fe988d1d5243eefec159 Mon Sep 17 00:00:00 2001
-From: Konstantin Lopuhin <kostia.lopuhin@gmail.com>
-Date: Wed, 18 Jun 2014 12:43:04 +0400
-Subject: [PATCH] fix parsing of bad dimensions
-
----
- xlrd/xlsx.py | 24 ++++++++++++++++++------
- 1 file changed, 18 insertions(+), 6 deletions(-)
-
-diff --git a/xlrd/xlsx.py b/xlrd/xlsx.py
-index 53fbb89..763df0c 100644
---- a/xlrd/xlsx.py
-+++ b/xlrd/xlsx.py
-@@ -73,7 +73,8 @@ def augment_keys(adict, uri):
-     _UPPERCASE_1_REL_INDEX[_x] = 0\r
- del _x\r
\r
--def cell_name_to_rowx_colx(cell_name, letter_value=_UPPERCASE_1_REL_INDEX):\r
-+def cell_name_to_rowx_colx(cell_name, letter_value=_UPPERCASE_1_REL_INDEX,\r
-+        allow_no_col=False):\r
-     # Extract column index from cell name\r
-     # A<row number> => 0, Z =>25, AA => 26, XFD => 16383\r
-     colx = 0\r
-@@ -85,9 +86,18 @@ def cell_name_to_rowx_colx(cell_name, letter_value=_UPPERCASE_1_REL_INDEX):
-             if lv:\r
-                 colx = colx * 26 + lv\r
-             else: # start of row number; can't be '0'\r
--                colx = colx - 1\r
--                assert 0 <= colx < X12_MAX_COLS\r
--                break\r
-+                if charx == 0:\r
-+                    # there was no col marker\r
-+                    if allow_no_col:\r
-+                        colx = None\r
-+                        break\r
-+                    else:\r
-+                        raise Exception(\r
-+                                'Missing col in cell name %r', cell_name)\r
-+                else:\r
-+                    colx = colx - 1\r
-+                    assert 0 <= colx < X12_MAX_COLS\r
-+                    break\r
-     except KeyError:\r
-         raise Exception('Unexpected character %r in cell name %r' % (c, cell_name))\r
-     rowx = int(cell_name[charx:]) - 1\r
-@@ -562,9 +572,11 @@ def do_dimension(self, elem):
-         if ref:\r
-             # print >> self.logfile, "dimension: ref=%r" % ref\r
-             last_cell_ref = ref.split(':')[-1] # example: "Z99"\r
--            rowx, colx = cell_name_to_rowx_colx(last_cell_ref)\r
-+            rowx, colx = cell_name_to_rowx_colx(\r
-+                    last_cell_ref, allow_no_col=True)\r
-             self.sheet._dimnrows = rowx + 1\r
--            self.sheet._dimncols = colx + 1\r
-+            if colx is not None:\r
-+                self.sheet._dimncols = colx + 1\r
\r
-     def do_merge_cell(self, elem):\r
-         # The ref attribute should be a cell range like "B1:D5".\r
diff --git a/dev-python/xlrd/xlrd-0.9.4.ebuild b/dev-python/xlrd/xlrd-0.9.4.ebuild
deleted file mode 100644 (file)
index ec0657e..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Library for developers to extract data from Microsoft Excel (tm) spreadsheet files"
-HOMEPAGE="
-       http://www.python-excel.org/
-       https://github.com/python-excel/xlrd/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~ppc-aix ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
-IUSE=""
-
-PATCHES=( "${FILESDIR}"/${PN}-0.9.3-column.patch )
-
-python_prepare_all() {
-       # Remove this if examples get reintroduced
-       sed -i -e "s/test_names_demo/_&/" tests/test_open_workbook.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       "${PYTHON}" -m unittest discover || die "Test failed with ${EPYTHON}"
-}