x11-misc/qtfm: Update live ebuild
authorJeroen Roovers <jer@gentoo.org>
Sun, 15 Dec 2019 14:26:26 +0000 (15:26 +0100)
committerJeroen Roovers <jer@gentoo.org>
Sun, 15 Dec 2019 16:28:03 +0000 (17:28 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
x11-misc/qtfm/files/qtfm-99999-cmake.patch
x11-misc/qtfm/qtfm-99999.ebuild

index a89d090510df7e2aca31cebde425d26de16cc5af..815453760fe21633a2a8bb015ccd47a63b71ffdc 100644 (file)
@@ -1,47 +1,10 @@
 --- a/CMakeLists.txt
 +++ b/CMakeLists.txt
-@@ -36,7 +36,7 @@
-         add_definitions(-DMAGICK7)
-     endif()
-     find_package(PkgConfig REQUIRED)
--    pkg_check_modules(MAGICK REQUIRED ImageMagick++)
-+    pkg_check_modules(MAGICK REQUIRED Magick++)
-     # ffmpeg
-     if(ENABLE_FFMPEG)
-         pkg_check_modules(AVDEVICE REQUIRED libavdevice)
-@@ -66,7 +66,7 @@
- find_package(Qt5Concurrent REQUIRED)
- # inotify
--if("${CMAKE_SYSTEM}" NOT MATCHES "Linux")
-+if(NOT "${CMAKE_SYSTEM_NAME}" MATCHES "Linux")
-     find_package(PkgConfig REQUIRED)
-     pkg_check_modules(NOTIFY REQUIRED libinotify)
- endif()
-@@ -123,7 +123,7 @@
+@@ -121,7 +121,6 @@ set_target_properties(
      ${PROJECT_VERSION_MAJOR}
  )
- if(ENABLE_MAGICK OR ENABLE_MAGICK7)
+ if(ENABLE_MAGICK)
 -    target_compile_definitions(QtFM PRIVATE ${MAGICK_CFLAGS_OTHER})
-+    target_compile_options(QtFM PRIVATE ${MAGICK_CFLAGS_OTHER})
      target_link_libraries(QtFM ${MAGICK_LIBRARIES})
      if(ENABLE_FFMPEG)
          target_include_directories(QtFM
-@@ -161,7 +161,7 @@
- if(ENABLE_DBUS)
-     target_link_libraries(QtFM Qt5::DBus QtFMBus)
- endif()
--if("${CMAKE_SYSTEM}" NOT MATCHES "Linux")
-+if(NOT "${CMAKE_SYSTEM_NAME}" MATCHES "Linux")
-     target_link_libraries(QtFM ${NOTIFY_LIBRARIES})
- endif()
- if(APPLE)
-@@ -192,7 +192,7 @@
- if(ENABLE_DBUS)
-     target_link_libraries(${PROJECT_NAME} Qt5::DBus)
- endif()
--if("${CMAKE_SYSTEM}" NOT MATCHES "Linux")
-+if(NOT "${CMAKE_SYSTEM_NAME}" MATCHES "Linux")
-     target_link_libraries(${PROJECT_NAME} ${NOTIFY_LIBRARIES})
- endif()
- if(APPLE)
index 012984f236ab07c81e2ebd87b9a143294109a3bb..61cdeb65e8606637a95f8af21a68da5c4457518e 100644 (file)
@@ -37,7 +37,7 @@ src_configure() {
        mycmakeargs=(
                -DENABLE_DBUS="$(usex dbus)"
                -DENABLE_FFMPEG="$(usex ffmpeg)"
-               -DENABLE_MAGICK7="$(usex imagemagick)"
+               -DENABLE_MAGICK="$(usex imagemagick)"
        )
        cmake-utils_src_configure
 }