Version bump wrt bug #153722
authorMarkus Ullmann <jokey@gentoo.org>
Wed, 29 Nov 2006 16:53:30 +0000 (16:53 +0000)
committerMarkus Ullmann <jokey@gentoo.org>
Wed, 29 Nov 2006 16:53:30 +0000 (16:53 +0000)
Package-Manager: portage-2.1.2_rc2-r2

net-analyzer/nessus-bin/ChangeLog
net-analyzer/nessus-bin/files/digest-nessus-bin-3.0.4 [new file with mode: 0644]
net-analyzer/nessus-bin/files/nessusd-initd [new file with mode: 0644]
net-analyzer/nessus-bin/nessus-bin-3.0.4.ebuild [new file with mode: 0644]

index 3c64251b315f0bb1680a226a0f18b7daab9f2864..c67bf90c3699f6629cd4edbafb352a672c5f81ad 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for net-analyzer/nessus-bin
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-bin/ChangeLog,v 1.4 2006/10/09 11:55:08 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-bin/ChangeLog,v 1.5 2006/11/29 16:53:30 jokey Exp $
+
+*nessus-bin-3.0.4 (29 Nov 2006)
+
+  29 Nov 2006; Markus Ullmann <jokey@gentoo.org> -files/nessusd-r8,
+  +files/nessusd-initd, -nessus-bin-3.0.2.ebuild, -nessus-bin-3.0.3.ebuild,
+  +nessus-bin-3.0.4.ebuild:
+  Version bump wrt bug #153722
 
 *nessus-bin-3.0.3 (09 Oct 2006)
 
diff --git a/net-analyzer/nessus-bin/files/digest-nessus-bin-3.0.4 b/net-analyzer/nessus-bin/files/digest-nessus-bin-3.0.4
new file mode 100644 (file)
index 0000000..db34b8a
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 c55a9d3acd0deca333d4e3e15bae1ae2 Nessus-3.0.4-suse10.0.i586.rpm 5682928
+RMD160 ce74d55930de29c244430016739a556892aa4010 Nessus-3.0.4-suse10.0.i586.rpm 5682928
+SHA256 4f72646866383a4f757b69b8e6fe37e91d6feac12d5eb5e3081a509bfa3d6202 Nessus-3.0.4-suse10.0.i586.rpm 5682928
diff --git a/net-analyzer/nessus-bin/files/nessusd-initd b/net-analyzer/nessus-bin/files/nessusd-initd
new file mode 100644 (file)
index 0000000..6cb2138
--- /dev/null
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-bin/files/nessusd-initd,v 1.1 2006/11/29 16:53:30 jokey Exp $
+
+depend() {
+       need net
+}
+
+start() {
+       ebegin "Starting nessusd"
+       start-stop-daemon --start --quiet --exec /opt/nessus/sbin/nessusd -- -D --quiet
+       eend $? 
+}
+
+stop() {
+       ebegin "Stop nessusd"
+       start-stop-daemon --stop --quiet --exec /opt/nessus/sbin/nessusd
+       einfo "Waiting for the environment to be sane"
+       while [ -n "$RUNNING" ] ; do
+               sleep 1
+               RUNNING=$(ps aux | grep -m 1 nessusd: | grep -v grep)
+       done
+       sleep 3
+       eend $?
+}
diff --git a/net-analyzer/nessus-bin/nessus-bin-3.0.4.ebuild b/net-analyzer/nessus-bin/nessus-bin-3.0.4.ebuild
new file mode 100644 (file)
index 0000000..7d1d2ef
--- /dev/null
@@ -0,0 +1,70 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-bin/nessus-bin-3.0.4.ebuild,v 1.1 2006/11/29 16:53:30 jokey Exp $
+
+inherit rpm
+
+MY_P="Nessus-${PV}-suse10.0.i586"
+# We are using SuSE's binary
+
+DESCRIPTION="A remote security scanner for Linux"
+HOMEPAGE="http://nessus.org"
+SRC_URI="${MY_P}.rpm"
+RESTRICT="nomirror fetch nostrip"
+
+LICENSE="Nessus-EULA"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="X"
+
+DEPEND="=sys-libs/db-4.3*
+       dev-libs/openssl"
+
+PDEPEND="X? ( net-analyzer/nessus-client )"
+
+pkg_nofetch() {
+       einfo "Please download ${MY_P}.rpm from ${HOMEPAGE}/download"
+       einfo "The archive should then be placed into ${DISTDIR}."
+}
+
+pkg_setup() {
+       case ${CHOST} in
+               i586-pc-linux-gnu*)     einfo "Found compatible architecture." ;;
+               i686-pc-linux-gnu*)     einfo "Found compatible architecture." ;;
+               *)                      die "No compatible architecture found." ;;
+       esac
+}
+
+src_install() {
+       # copy files
+       cp -pPR "${WORKDIR}"/opt "${D}"
+
+       # make sure these directories do not vanish
+       # nessus will not run properly without them
+       keepdir /opt/nessus/etc/nessus
+       keepdir /opt/nessus/var/nessus/jobs
+       keepdir /opt/nessus/var/nessus/logs
+       keepdir /opt/nessus/var/nessus/tmp
+       keepdir /opt/nessus/var/nessus/users
+
+       # add /opt/nessus/lib to LD_PATH
+       # nessus will not run properly without it
+       doenvd "${FILESDIR}"/90nessus-bin
+
+       # we have /bin/gzip, not /usr/bin/gzip
+       sed -i -e "s:/usr/bin/gzip:/bin/gzip:g" \
+               "${D}"/opt/nessus/sbin/nessus-update-plugins
+
+       # init script
+       newinitd "${FILESDIR}"/nessusd-initd nessusd-bin
+}
+
+pkg_postinst() {
+       einfo "You can get started running the following commands:"
+       einfo "/opt/nessus/sbin/nessus-add-first-user"
+       einfo "/opt/nessus/sbin/nessus-mkcert"
+       einfo "/etc/init.d/nessusd-bin start"
+       einfo
+       einfo "For more information about nessus, please visit"
+       einfo "${HOMEPAGE}/documentation/"
+}