dev-python/process-tests: New package, ebuild written by me
authorJustin Lecher <jlec@gentoo.org>
Wed, 9 Sep 2015 08:28:31 +0000 (10:28 +0200)
committerJustin Lecher <jlec@gentoo.org>
Wed, 9 Sep 2015 09:49:33 +0000 (11:49 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/process-tests/Manifest [new file with mode: 0644]
dev-python/process-tests/metadata.xml [new file with mode: 0644]
dev-python/process-tests/process-tests-1.1.0.ebuild [new file with mode: 0644]

diff --git a/dev-python/process-tests/Manifest b/dev-python/process-tests/Manifest
new file mode 100644 (file)
index 0000000..6766678
--- /dev/null
@@ -0,0 +1 @@
+DIST process-tests-1.1.0.tar.gz 5450 SHA256 38cccf8f9867c78aa18edf9ec40ca87ff0994af2d588ebf482504873557489fe SHA512 0fcb9a0f1e01bd800a72d0c0f946e58e76d01923abc3731c4cb7f589cc8655d6ad4440c339d497f388c009fd569e547c183f024fd0768a2d23afa558e09156ac WHIRLPOOL da4df1eb80a34701df81c355f6e23883e7563417ea428f0d873bdecf3a506bcb3a62b0f17d73020d45bd92eec5c8df33a68e0ffc8b948cfb25ff47222769d36e
diff --git a/dev-python/process-tests/metadata.xml b/dev-python/process-tests/metadata.xml
new file mode 100644 (file)
index 0000000..9ff7a64
--- /dev/null
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <herd>python</herd>
+       <maintainer>
+               <email>jlec@gentoo.org</email>
+               <name>Justin Lecher</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="pypi">pxml</remote-id>
+               <remote-id type="github">metagriffin/pxml</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/dev-python/process-tests/process-tests-1.1.0.ebuild b/dev-python/process-tests/process-tests-1.1.0.ebuild
new file mode 100644 (file)
index 0000000..75f622c
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tools for testing processes"
+HOMEPAGE="https://github.com/ionelmc/python-process-tests https://pypi.python.org/pypi/process-tests"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       "