x11-wm/marco: Add previously omitted dependency and bump to 1.22.1
authorNP-Hardass <NP-Hardass@gentoo.org>
Sun, 12 May 2019 20:20:11 +0000 (16:20 -0400)
committerGöktürk Yüksek <gokturk@gentoo.org>
Sun, 12 May 2019 21:01:39 +0000 (17:01 -0400)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
x11-wm/marco/Manifest
x11-wm/marco/marco-1.22.1.ebuild [new file with mode: 0644]

index fb432a05fda503102c381d88f8da5395e86ac4d1..c0e994e066ec4306ccf61c14f846cda350b1705d 100644 (file)
@@ -1 +1,2 @@
 DIST marco-1.22.0.tar.xz 1406400 BLAKE2B 4c3ebf92111e2d211f80e3cf65e9eab661a8157e51021b5178f621113d739efda45eb15af4e87479587b530c773a7f7bd4c3bf85ffb053da9bf0ee3529073dd7 SHA512 0935ca1532fde882e21ebbc67b41afe80e15e8519b413b9b8bde351196be347a8dcac2e092da818ec0bc700216e38211f192a891eafec8ac7d9bf63d3a42328d
+DIST marco-1.22.1.tar.xz 1357864 BLAKE2B 241e71795acfdcbf90070ef0d14f0cc55894a5cddbf48bd8741cf9580cfcaa035890b23a2182738875ce4d89d099a80d59aa7b1937e4a34a18a5a969830e7db9 SHA512 18093f4d419fbc90f957a04ec3e36a153b3c51a6bcdc1ac5884adcc0292f157bc5e4af51e171451a4b54b5bccffdee2e8a07ed13dafb6106773abfb06b6a8a4f
diff --git a/x11-wm/marco/marco-1.22.1.ebuild b/x11-wm/marco/marco-1.22.1.ebuild
new file mode 100644 (file)
index 0000000..0f12a94
--- /dev/null
@@ -0,0 +1,72 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE2_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+       KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="MATE default window manager"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="startup-notification test xinerama"
+
+COMMON_DEPEND="
+       dev-libs/atk
+       >=dev-libs/glib-2.50:2
+       >=gnome-base/libgtop-2:2=
+       media-libs/libcanberra[gtk3]
+       x11-libs/cairo
+       >=x11-libs/pango-1.2[X]
+       x11-libs/gdk-pixbuf:2
+       >=x11-libs/gtk+-3.22:3
+       x11-libs/libICE
+       x11-libs/libSM
+       x11-libs/libX11
+       >=x11-libs/libXcomposite-0.3
+       x11-libs/libXcursor
+       x11-libs/libXdamage
+       x11-libs/libXext
+       x11-libs/libXfixes
+       x11-libs/libXrandr
+       x11-libs/libXrender
+       >=x11-libs/startup-notification-0.7
+       virtual/libintl
+       xinerama? ( x11-libs/libXinerama )
+       !!x11-wm/mate-window-manager"
+
+RDEPEND="${COMMON_DEPEND}
+       gnome-extra/zenity
+       >=mate-base/mate-desktop-1.20.0"
+
+DEPEND="${COMMON_DEPEND}
+       app-text/yelp-tools
+       >=dev-util/intltool-0.34.90
+       sys-devel/gettext:*
+       virtual/pkgconfig:*
+       x11-base/xorg-proto
+       x11-libs/libXpresent
+       test? ( app-text/docbook-xml-dtd:4.5 )
+       xinerama? ( x11-base/xorg-proto )"
+
+src_configure() {
+       mate_src_configure \
+               --enable-compositor \
+               --enable-render \
+               --enable-shape \
+               --enable-sm \
+               --enable-xsync \
+               $(use_enable startup-notification) \
+               $(use_enable xinerama)
+}
+
+src_install() {
+       mate_src_install
+       dodoc {,doc/}*.txt
+}