net-misc/ntp: fix tests on ia64 and similar, bug #564018
authorSergei Trofimovich <slyfox@gentoo.org>
Mon, 23 Sep 2019 06:50:53 +0000 (07:50 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Thu, 10 Oct 2019 22:21:10 +0000 (23:21 +0100)
Avoid building problematic tests on platforms
whose linker does not support --gc-sections.

Bug: https://bugs.ntp.org/show_bug.cgi?id=3601
Closes: https://bugs.gentoo.org/564018
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
net-misc/ntp/files/ntp-4.2.8-gc-tests.patch [new file with mode: 0644]
net-misc/ntp/ntp-4.2.8_p13-r2.ebuild

diff --git a/net-misc/ntp/files/ntp-4.2.8-gc-tests.patch b/net-misc/ntp/files/ntp-4.2.8-gc-tests.patch
new file mode 100644 (file)
index 0000000..19f0c0f
--- /dev/null
@@ -0,0 +1,41 @@
+Avoid building problematic tests on platforms
+whose linker does not support --gc-sections.
+
+https://bugs.ntp.org/show_bug.cgi?id=3601
+https://bugs.gentoo.org/564018
+
+--- a/sntp/m4/ntp_problemtests.m4      2019-09-23 07:19:18.545861137 +0200
++++ b/sntp/m4/ntp_problemtests.m4      2019-09-23 07:19:18.545861137 +0200
+@@ -33,6 +33,10 @@
+  no:0:*-*-solaris*) ;;
+  *) ntp_test_ntp_restrict="yes" ;;
+ esac
++case "$ntp_cv_gc_sections_runs" in
++  no) ntp_test_ntp_restrict="no" ;;
++  * ) ;;
++esac
+ AC_MSG_RESULT([$ntp_test_ntp_restrict])
+ AM_CONDITIONAL([BUILD_TEST_NTP_RESTRICT], [test x$ntp_test_ntp_restrict = xyes])
+@@ -43,6 +47,10 @@
+  no:0:*-*-solaris*) ;;
+  *) ntp_test_ntp_scanner="yes" ;;
+ esac
++case "$ntp_cv_gc_sections_runs" in
++  no) ntp_test_ntp_scanner="no" ;;
++  * ) ;;
++esac
+ AC_MSG_RESULT([$ntp_test_ntp_scanner])
+ AM_CONDITIONAL([BUILD_TEST_NTP_SCANNER], [test x$ntp_test_ntp_scanner = xyes])
+@@ -53,6 +61,10 @@
+  no:0:*-*-solaris*) ;;
+  *) ntp_test_ntp_signd="yes" ;;
+ esac
++case "$ntp_cv_gc_sections_runs" in
++  no) ntp_test_ntp_signd="no" ;;
++  * ) ;;
++esac
+ AC_MSG_RESULT([$ntp_test_ntp_signd])
+ AM_CONDITIONAL([BUILD_TEST_NTP_SIGND], [test x$ntp_test_ntp_signd = xyes])
index 40f035bdcd4d518b979518cfc6febd8765e15e13..96d2441f9b39eb16cc4bb1c16795d74bfb8dfc07 100644 (file)
@@ -47,6 +47,7 @@ PATCHES=(
        "${FILESDIR}"/${PN}-4.2.8-sntp-test-pthreads.patch #563922
        "${FILESDIR}"/${PN}-4.2.8_p10-fix-build-wo-ssl-or-libressl.patch
        "${FILESDIR}"/${PN}-4.2.8_p12-libressl-2.8.patch
+       "${FILESDIR}"/${PN}-4.2.8-gc-tests.patch #564018
 )
 
 src_prepare() {