dev-python/smmap: Bump to 3.0.2
authorMichał Górny <mgorny@gentoo.org>
Sun, 12 Apr 2020 11:03:59 +0000 (13:03 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 12 Apr 2020 11:29:52 +0000 (13:29 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/smmap/Manifest
dev-python/smmap/smmap-3.0.2.ebuild [new file with mode: 0644]

index 40c69ceb92675512f0c7ef7031742a057f02cd1e..683e3aefcfae9f216fd8247c6b36579aa12c0f84 100644 (file)
@@ -1 +1,2 @@
 DIST smmap-3.0.1.tar.gz 23659 BLAKE2B 19a9425d039141acc00ddc939dab97390d6f619b2d9049ee9c8e483718da1dc06fcd937c6736ecf91a4d55af2b5ff7612de93690334fbfa9bc3904a597e517bd SHA512 36594896212d218c5bc9e27ae16f692643d2236ff13a55461a35d0d688fcf40f6082caa003f178d7bd8b999d4571de269d708f299413dbef46b58ae2074bfc9a
+DIST smmap-3.0.2.tar.gz 22511 BLAKE2B 26aa528628d9f923b883481e635292c7eeba70d37c8258dd242a5ff875ec4627c57c753e4ce72de6d19ef7227540689b6c410d941079ef5c1b279c30f65e50a0 SHA512 52db538f16b9d0bdbbb932c7eb67510facd0638ea69dec21e9d503c3381195130ac0bc1f48db24ca76b8e31b07279799a767dd7e1bf1d755e7f7684f3285b8da
diff --git a/dev-python/smmap/smmap-3.0.2.ebuild b/dev-python/smmap/smmap-3.0.2.ebuild
new file mode 100644 (file)
index 0000000..73277c5
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure Python implementation of a sliding window memory map manager"
+HOMEPAGE="
+       https://pypi.org/project/smmap/
+       https://github.com/Byron/smmap"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm64 ~x86"
+SLOT="0"
+
+distutils_enable_tests unittest