dev-python/ipyparallel: add conditional block on ipython-6 for python-2.7
authorSébastien Fabbro <bicatali@gentoo.org>
Sat, 19 Aug 2017 22:33:37 +0000 (22:33 +0000)
committerSébastien Fabbro <bicatali@gentoo.org>
Sat, 19 Aug 2017 22:33:37 +0000 (22:33 +0000)
Package-Manager: Portage-2.3.7, Repoman-2.3.3

dev-python/ipyparallel/ipyparallel-4.1.0.ebuild
dev-python/ipyparallel/ipyparallel-5.0.1.ebuild
dev-python/ipyparallel/ipyparallel-5.1.1.ebuild
dev-python/ipyparallel/ipyparallel-5.2.0.ebuild
dev-python/ipyparallel/ipyparallel-6.0.2-r1.ebuild [new file with mode: 0644]
dev-python/ipyparallel/ipyparallel-6.0.2.ebuild
dev-python/ipyparallel/metadata.xml

index 94b1c39303fce437bc32e0c1026d8517c1766698..62d09048ca07641da0549ef8c578aa7d1e2bd9f9 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -24,6 +24,7 @@ RDEPEND="
        dev-python/ipykernel[${PYTHON_USEDEP}]
        !<dev-python/ipython-4.0.0[smp]
        >=dev-python/ipython-4.0.0[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '<dev-python/ipython-6[${PYTHON_USEDEP}]' 'python2_7')
        dev-python/jupyter_client[${PYTHON_USEDEP}]
        "
 DEPEND="${RDEPEND}
index 3703b40eb6e4a8aa93d5516b150cb31980a36d81..d7477fdddfac03b0c11bb69e608a1dddc1d1f9d6 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -24,6 +24,7 @@ RDEPEND="
        dev-python/ipykernel[${PYTHON_USEDEP}]
        !<dev-python/ipython-4.0.0[smp]
        >=dev-python/ipython-4.0.0[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '<dev-python/ipython-6[${PYTHON_USEDEP}]' 'python2_7')
        dev-python/jupyter_client[${PYTHON_USEDEP}]
        "
 DEPEND="${RDEPEND}
index 6012661d73f3917cb6e37eb052c4fc6c0615f699..459d8e5dc1b13769173f5d4164110fcf7111dc95 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -24,6 +24,7 @@ RDEPEND="
        dev-python/ipykernel[${PYTHON_USEDEP}]
        !<dev-python/ipython-4.0.0[smp]
        >=dev-python/ipython-4.0.0[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '<dev-python/ipython-6[${PYTHON_USEDEP}]' 'python2_7')
        dev-python/notebook[${PYTHON_USEDEP}]
        dev-python/jupyter_client[${PYTHON_USEDEP}]
        www-servers/tornado[${PYTHON_USEDEP}]
index 5dd5e10510cc14ea35f03532bd324d392c2882d2..41ea11d938aad6a5fd93d6654b514ba9feaf437a 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -24,6 +24,7 @@ RDEPEND="
        dev-python/ipykernel[${PYTHON_USEDEP}]
        !<dev-python/ipython-4.0.0[smp]
        >=dev-python/ipython-4.0.0[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '<dev-python/ipython-6[${PYTHON_USEDEP}]' 'python2_7')
        dev-python/notebook[${PYTHON_USEDEP}]
        dev-python/jupyter_client[${PYTHON_USEDEP}]
        www-servers/tornado[${PYTHON_USEDEP}]
diff --git a/dev-python/ipyparallel/ipyparallel-6.0.2-r1.ebuild b/dev-python/ipyparallel/ipyparallel-6.0.2-r1.ebuild
new file mode 100644 (file)
index 0000000..5b18b53
--- /dev/null
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Interactive Parallel Computing with IPython"
+HOMEPAGE="https://ipyparallel.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+       dev-python/decorator[${PYTHON_USEDEP}]
+       dev-python/ipykernel[${PYTHON_USEDEP}]
+       !<dev-python/ipython-4.0.0[smp,${PYTHON_USEDEP}]
+       >=dev-python/ipython-4.0.0[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '<dev-python/ipython-6[${PYTHON_USEDEP}]' 'python2_7')
+       dev-python/ipython_genutils[${PYTHON_USEDEP}]
+       dev-python/jupyter_client[${PYTHON_USEDEP}]
+       dev-python/notebook[${PYTHON_USEDEP}]
+       dev-python/python-dateutil[${PYTHON_USEDEP}]
+       >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
+       www-servers/tornado[${PYTHON_USEDEP}]
+       "
+DEPEND="${RDEPEND}
+       virtual/python-futures[${PYTHON_USEDEP}]
+       >=dev-python/setuptools-18.5[${PYTHON_USEDEP}]
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+       test? (
+               dev-python/mock[${PYTHON_USEDEP}]
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/pytest-cov[${PYTHON_USEDEP}]
+               dev-python/testpath[${PYTHON_USEDEP}]
+       )
+       "
+
+python_prepare_all() {
+       # Prevent un-needed download during build
+       if use doc; then
+               sed -e "/^    'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
+       fi
+
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+       if use doc; then
+               emake -C docs html
+               HTML_DOCS=( docs/build/html/. )
+       fi
+}
+
+python_test() {
+       iptest --coverage xml ipyparallel.tests -- -vsx || die
+}
index 3f686896a645a6cc1e6497c296425f295db2774f..646d41f54228a618ad411b6012085de7f08657de 100644 (file)
@@ -25,6 +25,7 @@ RDEPEND="
        dev-python/ipykernel[${PYTHON_USEDEP}]
        !<dev-python/ipython-4.0.0[smp]
        >=dev-python/ipython-4.0.0[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '<dev-python/ipython-6[${PYTHON_USEDEP}]' 'python2_7')
        dev-python/notebook[${PYTHON_USEDEP}]
        dev-python/jupyter_client[${PYTHON_USEDEP}]
        www-servers/tornado[${PYTHON_USEDEP}]
index f58431f0f4bc3dfa9e5828f365f3bd85227fbb92..742b296901f63a2e0294be21fb6ad217aba754db 100644 (file)
@@ -6,7 +6,7 @@
     <name>Gentoo Science Project</name>
   </maintainer>
   <longdescription>
-       Interactive Parallel Computing with IPython.
+    Interactive Parallel Computing with IPython.
     ipyparallel is the new home of IPython.parallel.
   </longdescription>
   <upstream>