dev-python/mkdocs-bootstrap: version bump 1.1
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>
Sat, 28 Mar 2020 14:13:12 +0000 (15:13 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 9 Apr 2020 12:37:42 +0000 (15:37 +0300)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-python/mkdocs-bootstrap/Manifest
dev-python/mkdocs-bootstrap/metadata.xml
dev-python/mkdocs-bootstrap/mkdocs-bootstrap-1.1.ebuild [new file with mode: 0644]

index 0563e4bc0cb233bb21d11e9857273bc8d1c13475..5b78ffe117adeb208b5e2a4545202b13ef36dc19 100644 (file)
@@ -1 +1,2 @@
 DIST mkdocs-bootstrap-0.1.1.tar.gz 363121 BLAKE2B aecbbab8a0ede98d52cca778d6d8430945f3b1e962f3bd4b3a5c0d544c51d0a06a21e4d0b15390640097d57b8f30ea5f271d201ef9ed0a15ff034e08e1529e33 SHA512 edaf4178f2a5914bf6fb7daaf4dfeabe42eff6872e60ca78bf748b55bb2e487742ada279696ee6f8aad87106d38e7bcf0e24460b85d441b5f77e4f64a99a4b66
+DIST mkdocs-bootstrap-1.1.tar.gz 233231 BLAKE2B 64470a4e5ca6d44976944c16244daaefa99702fa68d68fb14e31201fcfd5f927dc2b962fd0b1967a6fd7eec8719389a78dd13cbfcdc387fa6de5f21c9c1a4960 SHA512 a494afa614f96771fbc640862b5cb5674d4eb5c978a56e86e2f523137fed315808067f20cfadca463cbeb5384de062c91001b6eaf5f3ebdce329f167b461d2b5
index d351c1e4ca549dc12100d01879636954eb7e3b85..dffd79f75c7e221b0eb71b7fd6f33cbbcc0b557c 100644 (file)
@@ -1,7 +1,14 @@
 <?xml version='1.0' encoding='UTF-8'?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-       <!--maintainer-needed-->
+       <maintainer type="person">
+               <email>andrewammerlaan@riseup.net</email>
+               <name>Andrew Ammerlaan</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
        <upstream>
                <remote-id type="pypi">mkdocs-bootstrap</remote-id>
        </upstream>
diff --git a/dev-python/mkdocs-bootstrap/mkdocs-bootstrap-1.1.ebuild b/dev-python/mkdocs-bootstrap/mkdocs-bootstrap-1.1.ebuild
new file mode 100644 (file)
index 0000000..9720eb3
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Bootstrap theme for MkDocs"
+HOMEPAGE="https://www.mkdocs.org https://github.com/mkdocs/mkdocs-bootstrap"
+SRC_URI="https://github.com/mkdocs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc"
+
+DEPEND="dev-python/mkdocs"
+
+python_compile_all() {
+       default
+       if use doc; then
+               mkdocs build || die "Failed to make docs"
+               # Colliding files found by ecompress:
+               rm site/sitemap.xml.gz || die
+               HTML_DOCS=( "site/." )
+       fi
+}