new upstream release.
authorAkinori Hattori <hattya@gentoo.org>
Fri, 19 Jan 2007 10:21:03 +0000 (10:21 +0000)
committerAkinori Hattori <hattya@gentoo.org>
Fri, 19 Jan 2007 10:21:03 +0000 (10:21 +0000)
Package-Manager: portage-2.1.1-r2

app-i18n/anthy-ss/ChangeLog
app-i18n/anthy-ss/anthy-ss-8517.ebuild [new file with mode: 0644]
app-i18n/anthy-ss/files/digest-anthy-ss-8517 [new file with mode: 0644]

index 2a16fb221848ffa2bcd2e369fd6e5f5924a6c1a2..4240e874d76032286a0d1b304d683e7f46558380 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for app-i18n/anthy-ss
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/ChangeLog,v 1.94 2006/12/24 14:47:04 hattya Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/ChangeLog,v 1.95 2007/01/19 10:21:03 hattya Exp $
+
+*anthy-ss-8517 (19 Jan 2007)
+
+  19 Jan 2007; Akinori Hattori <hattya@gentoo.org> -anthy-ss-8419.ebuild,
+  +anthy-ss-8517.ebuild:
+  new upstream release.
 
 *anthy-ss-8419 (24 Dec 2006)
 
diff --git a/app-i18n/anthy-ss/anthy-ss-8517.ebuild b/app-i18n/anthy-ss/anthy-ss-8517.ebuild
new file mode 100644 (file)
index 0000000..737b759
--- /dev/null
@@ -0,0 +1,74 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/anthy-ss-8517.ebuild,v 1.1 2007/01/19 10:21:03 hattya Exp $
+
+inherit elisp-common eutils
+
+IUSE="emacs ucs4"
+
+MY_P=${P/-ss/}
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/anthy/23615/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+SLOT="0"
+S=${WORKDIR}/${MY_P}
+
+DEPEND="!app-i18n/anthy
+       emacs? ( virtual/emacs )"
+
+src_unpack() {
+
+       unpack ${A}
+       cd "${S}"
+
+       local cannadicdir=/var/lib/canna/dic/canna
+
+       if has_version 'app-dicts/canna-2ch'; then
+               einfo "Adding nichan.ctd to anthy.dic."
+               sed -i /placename/a"read ${cannadicdir}/nichan.ctd" \
+                       mkworddic/dict.args.in
+       fi
+
+}
+
+src_compile() {
+
+       local myconf
+
+       use emacs || myconf="EMACS=no"
+       use ucs4 && myconf="${myconf} --enable-ucs4"
+
+       econf ${myconf} || die
+       emake || die
+
+}
+
+src_install() {
+
+       emake DESTDIR="${D}" install || die
+
+       use emacs && elisp-site-file-install "${FILESDIR}"/50anthy-gentoo.el
+
+       dodoc AUTHORS DIARY NEWS README ChangeLog
+
+       docinto doc
+       rm doc/Makefile*
+       dodoc doc/*
+
+}
+
+pkg_postinst() {
+
+       use emacs && elisp-site-regen
+
+}
+
+pkg_postrm() {
+
+       has_version virtual/emacs && elisp-site-regen
+
+}
diff --git a/app-i18n/anthy-ss/files/digest-anthy-ss-8517 b/app-i18n/anthy-ss/files/digest-anthy-ss-8517
new file mode 100644 (file)
index 0000000..94e29f8
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 d7374d5e4717a9b7f72c56deddb96f39 anthy-8517.tar.gz 3546021
+RMD160 0cdb3a64ed8fa61b618cafb2614d243dfaafcc0c anthy-8517.tar.gz 3546021
+SHA256 7772a3968071c12f51656ef5e9102ea3b9fecf6b55cd29841ae3abf5525e4b82 anthy-8517.tar.gz 3546021