net-im/bitlbee: remove unnecessary chown from pkg_postinst phase
authorPetr Vaněk <arkamar@atlas.cz>
Fri, 1 May 2020 12:04:33 +0000 (14:04 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 5 May 2020 08:46:35 +0000 (11:46 +0300)
Closes: https://bugs.gentoo.org/630912
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Petr Vaněk <arkamar@atlas.cz>
Closes: https://github.com/gentoo/gentoo/pull/14984
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
net-im/bitlbee/bitlbee-3.5.1.ebuild
net-im/bitlbee/bitlbee-3.6-r1.ebuild
net-im/bitlbee/bitlbee-9999.ebuild

index b637b82642cc16f90b06b962587db871ccf77f7e..5bae1f674e269b038dcc11029afe4f19ad4c874a 100644 (file)
@@ -147,10 +147,6 @@ src_install() {
 }
 
 pkg_postinst() {
-       chown -R bitlbee:bitlbee "${ROOT}"/var/lib/bitlbee
-       [[ -d "${ROOT}"/var/run/bitlbee ]] &&
-               chown -R bitlbee:bitlbee "${ROOT}"/var/run/bitlbee
-
        if [[ -z ${REPLACING_VERSIONS} ]]; then
                einfo
                elog "The bitlbee init script will now attempt to stop all processes owned by the"
index 847614625a9255f1798c1b3921e78c80fdf18470..28e2ef6bf5e246a62f72c1ea6f67bbd2de8f5f81 100644 (file)
@@ -150,7 +150,3 @@ src_install() {
        exeinto /usr/share/bitlbee
        doexe utils/{convert_purple.py,bitlbee-ctl.pl}
 }
-
-pkg_postinst() {
-       chown -R bitlbee:bitlbee "${ROOT}"/var/lib/bitlbee
-}
index 37efbe6e16b407684850b422e41d123b3ca77cc5..b76660b5f28b4747d71f6721e7251b0c47111232 100644 (file)
@@ -148,7 +148,3 @@ src_install() {
        exeinto /usr/share/bitlbee
        doexe utils/{convert_purple.py,bitlbee-ctl.pl}
 }
-
-pkg_postinst() {
-       chown -R bitlbee:bitlbee "${ROOT}"/var/lib/bitlbee
-}