dev-util/radare2: don't try to install doc/ subdirs, bug #574866
authorSergei Trofimovich <slyfox@gentoo.org>
Thu, 18 Feb 2016 23:21:14 +0000 (23:21 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Thu, 18 Feb 2016 23:21:25 +0000 (23:21 +0000)
Reported-by: Andrey Golovizin
Bug: https://bugs.gentoo.org/574866

Package-Manager: portage-2.2.27

dev-util/radare2/radare2-0.10.0.ebuild

index 8c8badd448ad21795fe340be7603a19e501b3678..c43c45737d8da52152ecabcd6a601d6a7f2353f3 100644 (file)
@@ -28,3 +28,15 @@ src_configure() {
        econf \
                $(use_with ssl openssl)
 }
+
+src_install() {
+       # a workaround for unstable $(INSTALL) call, bug #574866
+       local d
+       for d in doc/*; do
+               if [[ -d $d ]]; then
+                       rm -rfv "$d" || die "failed to delete '$d'"
+               fi
+       done
+
+       default
+}