net-libs/nodejs: Old
authorJeroen Roovers <jer@gentoo.org>
Sat, 26 Jan 2019 16:22:44 +0000 (17:22 +0100)
committerJeroen Roovers <jer@gentoo.org>
Sat, 26 Jan 2019 16:23:57 +0000 (17:23 +0100)
Package-Manager: Portage-2.3.58, Repoman-2.3.12
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-libs/nodejs/Manifest
net-libs/nodejs/nodejs-11.6.0.ebuild [deleted file]

index f9ef4ae038fffaf61144a5cfe433e0b66791e211..fcd93ebc7ac9815c4d1abe85104db6808bc268d4 100644 (file)
@@ -1,6 +1,5 @@
 DIST node-v0.12.18.tar.gz 19842591 BLAKE2B f94f4de6e2875267be194580c645087a262b90da99f10d651a22838c041da07056df81204bb04ce8da083a080062509dcca4d1e3ac2250d651ead8a4cc025028 SHA512 6866608a43eb213f3b715ea0fcc28983fd959ab679c567a1b464f62acd936506f2bce88ea48a60209d8ef8d98259f4b47cd3434893eb4ff82a132775edb37b7b
 DIST node-v10.15.0.tar.xz 20217588 BLAKE2B ef7f626bd3b13b11a1cbf21f5c6a2ce08567dddc2fb525c5f10e02f81750a648245c2eb88535d8aac1b055a13d12f9ead72d55c4ccf68062940da09d582344c3 SHA512 6c10ae4070cd8b89d4d31ee2137453fa582cef85c6f002c78d5029ceedddf5caeee8e28a4e75dfc632c3af3c8e2acec403ab17a927ba51fa31175d58b45cbf49
-DIST node-v11.6.0.tar.xz 20410716 BLAKE2B bf6150a42070f714dfa5a38da70a4ce6b6a81ca5b9aedb84e672dff5244676ce77ca771ee46d34adc7cd7b84a0fe91537f9cbd3841a95c4bee67a894d4e8b4e7 SHA512 7e3ee41a5de8395669796cf8f81a9e8f584ceda480b54874fceb057ccf8aa5b986239ca842b2dbd796dd1a97f9e2111995b334278f6d7bf38421a84c4e883c65
 DIST node-v11.7.0.tar.xz 21218124 BLAKE2B a7e69dc8d6ee2f42ea78ec9c4d623b56bfbc2e130fc6b7d33038ce79f03d7b92e78545fa26bb2dbd58c1c25677f0b224077822264fd9cec49e71f18517098563 SHA512 eec2d5e67d94314f1a09f3a1c3407d6b12e9decbdff99d41eb487c4ddc1929fc5661be0b6fbb180961ecb6094311630b19faa0af031d82ff8de7ae213ee35ab7
 DIST node-v11.8.0.tar.xz 21253080 BLAKE2B 808df024b7dba628f03b7c6c2fe8c486bb036f02f80aa2184de0a8393afad17dcd19d98fd63f1ffc5f9c1dc4fb078f32d15217322d1608510f291eef456df35f SHA512 7c33984014c2b95bde59affee88bc77caa2788dbdd7db87150acd58c56304932bf4b030994c91fc655f0f32202b8d1ed370c3d19d09569af50ffce91414d62ac
 DIST node-v4.9.1.tar.xz 13250164 BLAKE2B 7a689b99bb4bf507f7f21dd2c096a5766d023a8174c0f468cab37365af1920b8700da04157e1a406917790524255ef32c243a74662fd50ef7d3567d189dac9cf SHA512 690c9fdf608e5194069a10955bdd94ec87cb1c308f13bc4d2cae92fa01436ace10fadf58f2e51d477dde6c570b23edc1c71fafea79bfc9cab2903eb2fa5f87aa
diff --git a/net-libs/nodejs/nodejs-11.6.0.ebuild b/net-libs/nodejs/nodejs-11.6.0.ebuild
deleted file mode 100644 (file)
index 69a0e9f..0000000
+++ /dev/null
@@ -1,207 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="threads"
-
-inherit bash-completion-r1 eutils flag-o-matic pax-utils python-single-r1 toolchain-funcs
-
-DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
-HOMEPAGE="https://nodejs.org/"
-SRC_URI="https://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz"
-
-LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x64-macos"
-IUSE="cpu_flags_x86_sse2 debug doc icu inspector +npm +snapshot +ssl systemtap test"
-REQUIRED_USE="
-       ${PYTHON_REQUIRED_USE}
-       inspector? ( icu ssl )
-       npm? ( ssl )
-"
-
-RDEPEND="
-       >=dev-libs/libuv-1.24.1:=
-       >=net-dns/c-ares-1.15.0
-       >=net-libs/http-parser-2.9.0:=
-       >=net-libs/nghttp2-1.34.0
-       sys-libs/zlib
-       icu? ( >=dev-libs/icu-63.1:= )
-       ssl? ( =dev-libs/openssl-1.1.0*:0= )
-"
-DEPEND="
-       ${RDEPEND}
-       ${PYTHON_DEPS}
-       systemtap? ( dev-util/systemtap )
-       test? ( net-misc/curl )
-"
-PATCHES=(
-       "${FILESDIR}"/${PN}-10.3.0-global-npm-config.patch
-       "${FILESDIR}"/${PN}-11.4.0-stdarg_h.patch
-       "${FILESDIR}"/${PN}-99999999-llhttp.patch
-)
-S="${WORKDIR}/node-v${PV}"
-
-pkg_pretend() {
-       (use x86 && ! use cpu_flags_x86_sse2) && \
-               die "Your CPU doesn't support the required SSE2 instruction."
-
-       ( [[ ${MERGE_TYPE} != "binary" ]] && ! test-flag-CXX -std=c++11 ) && \
-               die "Your compiler doesn't support C++11. Use GCC 4.8, Clang 3.3 or newer."
-}
-
-src_prepare() {
-       tc-export CC CXX PKG_CONFIG
-       export V=1
-       export BUILDTYPE=Release
-
-       # fix compilation on Darwin
-       # https://code.google.com/p/gyp/issues/detail?id=260
-       sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
-
-       # make sure we use python2.* while using gyp
-       sed -i -e "s/python/${EPYTHON}/" deps/npm/node_modules/node-gyp/gyp/gyp || die
-       sed -i -e "s/|| 'python2'/|| '${EPYTHON}'/" deps/npm/node_modules/node-gyp/lib/configure.js || die
-
-       # less verbose install output (stating the same as portage, basically)
-       sed -i -e "/print/d" tools/install.py || die
-
-       # proper libdir, hat tip @ryanpcmcquen https://github.com/iojs/io.js/issues/504
-       local LIBDIR=$(get_libdir)
-       sed -i -e "s|lib/|${LIBDIR}/|g" tools/install.py || die
-       sed -i -e "s/'lib'/'${LIBDIR}'/" deps/npm/lib/npm.js || die
-
-       # Avoid writing a depfile, not useful
-       sed -i -e "/DEPFLAGS =/d" tools/gyp/pylib/gyp/generator/make.py || die
-
-       sed -i -e "/'-O3'/d" common.gypi deps/v8/gypfiles/toolchain.gypi || die
-
-       # Avoid a test that I've only been able to reproduce from emerge. It doesnt
-       # seem sandbox related either (invoking it from a sandbox works fine).
-       # The issue is that no stdin handle is openened when asked for one.
-       # It doesn't really belong upstream , so it'll just be removed until someone
-       # with more gentoo-knowledge than me (jbergstroem) figures it out.
-       rm test/parallel/test-stdout-close-unref.js || die
-
-       # debug builds. change install path, remove optimisations and override buildtype
-       if use debug; then
-               sed -i -e "s|out/Release/|out/Debug/|g" tools/install.py || die
-               BUILDTYPE=Debug
-       fi
-
-       default
-}
-
-src_configure() {
-       local myconf=( --shared-cares --shared-http-parser --shared-libuv --shared-nghttp2 --shared-zlib )
-       use debug && myconf+=( --debug )
-       use icu && myconf+=( --with-intl=system-icu ) || myconf+=( --with-intl=none )
-       use inspector || myconf+=( --without-inspector )
-       use npm || myconf+=( --without-npm )
-       use snapshot && myconf+=( --with-snapshot )
-       use ssl && myconf+=( --shared-openssl ) || myconf+=( --without-ssl )
-
-       local myarch=""
-       case ${ABI} in
-               amd64) myarch="x64";;
-               arm) myarch="arm";;
-               arm64) myarch="arm64";;
-               ppc64) myarch="ppc64";;
-               x32) myarch="x32";;
-               x86) myarch="ia32";;
-               *) myarch="${ABI}";;
-       esac
-
-       GYP_DEFINES="linux_use_gold_flags=0
-               linux_use_bundled_binutils=0
-               linux_use_bundled_gold=0" \
-       "${PYTHON}" configure \
-               --prefix="${EPREFIX}"/usr \
-               --dest-cpu=${myarch} \
-               $(use_with systemtap dtrace) \
-               "${myconf[@]}" || die
-}
-
-src_compile() {
-       emake -C out mksnapshot
-       pax-mark m "out/${BUILDTYPE}/mksnapshot"
-       emake -C out
-}
-
-src_install() {
-       local LIBDIR="${ED}/usr/$(get_libdir)"
-       emake install DESTDIR="${D}"
-       pax-mark -m "${ED}"usr/bin/node
-
-       # set up a symlink structure that node-gyp expects..
-       dodir /usr/include/node/deps/{v8,uv}
-       dosym . /usr/include/node/src
-       for var in deps/{uv,v8}/include; do
-               dosym ../.. /usr/include/node/${var}
-       done
-
-       if use doc; then
-               # Patch docs to make them offline readable
-               for i in `grep -rl 'fonts.googleapis.com' "${S}"/out/doc/api/*`; do
-                       sed -i '/fonts.googleapis.com/ d' $i;
-               done
-               # Install docs
-               docinto html
-               dodoc -r "${S}"/doc/*
-       fi
-
-       if use npm; then
-               dodir /etc/npm
-
-               # Install bash completion for `npm`
-               # We need to temporarily replace default config path since
-               # npm otherwise tries to write outside of the sandbox
-               local npm_config="usr/$(get_libdir)/node_modules/npm/lib/config/core.js"
-               sed -i -e "s|'/etc'|'${ED}/etc'|g" "${ED}/${npm_config}" || die
-               local tmp_npm_completion_file="$(emktemp)"
-               "${ED}/usr/bin/npm" completion > "${tmp_npm_completion_file}"
-               newbashcomp "${tmp_npm_completion_file}" npm
-               sed -i -e "s|'${ED}/etc'|'/etc'|g" "${ED}/${npm_config}" || die
-
-               # Move man pages
-               doman "${LIBDIR}"/node_modules/npm/man/man{1,5,7}/*
-
-               # Clean up
-               rm "${LIBDIR}"/node_modules/npm/{.mailmap,.npmignore,Makefile} || die
-               rm -rf "${LIBDIR}"/node_modules/npm/{doc,html,man} || die
-
-               local find_exp="-or -name"
-               local find_name=()
-               for match in "AUTHORS*" "CHANGELOG*" "CONTRIBUT*" "README*" \
-                       ".travis.yml" ".eslint*" ".wercker.yml" ".npmignore" \
-                       "*.md" "*.markdown" "*.bat" "*.cmd"; do
-                       find_name+=( ${find_exp} "${match}" )
-               done
-
-               # Remove various development and/or inappropriate files and
-               # useless docs of dependend packages.
-               find "${LIBDIR}"/node_modules \
-                       \( -type d -name examples \) -or \( -type f \( \
-                               -iname "LICEN?E*" \
-                               "${find_name[@]}" \
-                       \) \) -exec rm -rf "{}" \;
-       fi
-
-       mv "${ED}"/usr/share/doc/node "${ED}"/usr/share/doc/${PF} || die
-}
-
-src_test() {
-       out/${BUILDTYPE}/cctest || die
-       "${PYTHON}" tools/test.py --mode=${BUILDTYPE,,} -J message parallel sequential || die
-}
-
-pkg_postinst() {
-       einfo "The global npm config lives in /etc/npm. This deviates slightly"
-       einfo "from upstream which otherwise would have it live in /usr/etc/."
-       einfo ""
-       einfo "Protip: When using node-gyp to install native modules, you can"
-       einfo "avoid having to download extras by doing the following:"
-       einfo "$ node-gyp --nodedir /usr/include/node <command>"
-}