sys-boot/grub: add platform xen_pvh
authorJonas Licht <jonas.licht@fem.tu-ilmenau.de>
Fri, 18 Oct 2019 21:08:57 +0000 (23:08 +0200)
committerMike Gilbert <floppym@gentoo.org>
Tue, 29 Oct 2019 21:11:31 +0000 (17:11 -0400)
Closes: https://bugs.gentoo.org/697978
Closes: https://github.com/gentoo/gentoo/pull/13334
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Jonas Licht <jonas.licht@fem.tu-ilmenau.de>
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
profiles/arch/powerpc/package.use.mask
profiles/desc/grub_platforms.desc
sys-boot/grub/grub-2.04-r1.ebuild
sys-boot/grub/grub-9999.ebuild

index 444f0f94f384bf965d5c59ce39fb80845fc9c561..67dd6101c6044c25fc66b62e74df53b9376deefb 100644 (file)
@@ -46,7 +46,7 @@ net-analyzer/icinga2 mariadb
 
 # Luca Barbato <lu_zero@gentoo.org> (2018-08-12)
 # grub pc is not supported on powerpc
-sys-boot/grub:2 grub_platforms_pc grub_platforms_efi-32 grub_platforms_efi-64 grub_platforms_xen
+sys-boot/grub:2 grub_platforms_pc grub_platforms_efi-32 grub_platforms_efi-64 grub_platforms_xen grub_platforms_xen-pvh
 
 # Luke Dashjr <luke-jr+gentoobugs@utopios.org> (2018-06-08)
 # Requires unported sys-libs/netbsd-csu
index ef7153c971a42a337c8671fe12e82aad7c3b475c..b5978a32dba194c0b16f33c0f9c5f7d20d8c589b 100644 (file)
@@ -18,3 +18,4 @@ qemu-mips - QEMU MIPS platform support
 uboot - U-Boot platform support
 xen - XEN (pvgrub2) platform support
 xen-32 - Build 32-bit XEN (pvgrub2) platform support on amd64
+xen-pvh - XEN (pvhgrub2) platform support
index 81bd769728c964d21384b3abdaca3318bac5cd3b..7135f70c7f9843611262ac370d34163842e4d88f 100644 (file)
@@ -55,7 +55,7 @@ LICENSE="GPL-3 fonts? ( GPL-2-with-font-exception ) themes? ( BitstreamVera )"
 SLOT="2/${PVR}"
 IUSE="device-mapper doc efiemu +fonts mount nls sdl test +themes truetype libzfs"
 
-GRUB_ALL_PLATFORMS=( coreboot efi-32 efi-64 emu ieee1275 loongson multiboot qemu qemu-mips pc uboot xen xen-32 )
+GRUB_ALL_PLATFORMS=( coreboot efi-32 efi-64 emu ieee1275 loongson multiboot qemu qemu-mips pc uboot xen xen-32 xen-pvh )
 IUSE+=" ${GRUB_ALL_PLATFORMS[@]/#/grub_platforms_}"
 
 REQUIRED_USE="
@@ -105,6 +105,7 @@ DEPEND="
        ppc64? ( >=sys-apps/ibm-powerpc-utils-1.3.5 )
        grub_platforms_xen? ( app-emulation/xen-tools:= )
        grub_platforms_xen-32? ( app-emulation/xen-tools:= )
+       grub_platforms_xen-pvh? ( app-emulation/xen-tools:= )
 "
 RDEPEND="${DEPEND}
        kernel_linux? (
@@ -177,6 +178,7 @@ grub_configure() {
 
        case ${MULTIBUILD_VARIANT} in
                efi*) platform=efi ;;
+               xen-pvh) platform=xen_pvh ;;
                xen*) platform=xen ;;
                guessed) ;;
                *) platform=${MULTIBUILD_VARIANT} ;;
index 07f21fac67051c2eb1359da4260a8fcdda801cf2..6b165af82481c24db73b021f0340def204e8a36d 100644 (file)
@@ -54,7 +54,7 @@ LICENSE="GPL-3 fonts? ( GPL-2-with-font-exception ) themes? ( BitstreamVera )"
 SLOT="2/${PVR}"
 IUSE="device-mapper doc efiemu +fonts mount nls sdl test +themes truetype libzfs"
 
-GRUB_ALL_PLATFORMS=( coreboot efi-32 efi-64 emu ieee1275 loongson multiboot qemu qemu-mips pc uboot xen xen-32 )
+GRUB_ALL_PLATFORMS=( coreboot efi-32 efi-64 emu ieee1275 loongson multiboot qemu qemu-mips pc uboot xen xen-32 xen-pvh )
 IUSE+=" ${GRUB_ALL_PLATFORMS[@]/#/grub_platforms_}"
 
 REQUIRED_USE="
@@ -104,6 +104,7 @@ DEPEND="
        ppc64? ( >=sys-apps/ibm-powerpc-utils-1.3.5 )
        grub_platforms_xen? ( app-emulation/xen-tools:= )
        grub_platforms_xen-32? ( app-emulation/xen-tools:= )
+       grub_platforms_xen-pvh? ( app-emulation/xen-tools:= )
 "
 RDEPEND="${DEPEND}
        kernel_linux? (
@@ -176,6 +177,7 @@ grub_configure() {
 
        case ${MULTIBUILD_VARIANT} in
                efi*) platform=efi ;;
+               xen-pvh) platform=xen_pvh ;;
                xen*) platform=xen ;;
                guessed) ;;
                *) platform=${MULTIBUILD_VARIANT} ;;