dev-python/booleanOperations: Bump to 0.9.0
authorPacho Ramos <pacho@gentoo.org>
Wed, 11 Mar 2020 20:02:23 +0000 (21:02 +0100)
committerPacho Ramos <pacho@gentoo.org>
Wed, 11 Mar 2020 21:28:52 +0000 (22:28 +0100)
Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
dev-python/booleanOperations/Manifest
dev-python/booleanOperations/booleanOperations-0.9.0.ebuild [new file with mode: 0644]

index 5114320b3bf3e98b1211de8019ebf33bc2c85a13..cd1dc5492b53e30a2cc2a9663af1aa48c525769a 100644 (file)
@@ -1 +1,2 @@
 DIST booleanOperations-0.8.2.tar.gz 165059 BLAKE2B 978b992e84181e8ec437e236e6502a6c135ea011395f3b082881e6b9f5c849632077737064d1102164cf083edc8a7e47c6f4f43d858948d9046ed231c5ac8911 SHA512 3c369ce53bc7b1b53f4441ba79959d4853c9ab767fef17fc41f44812427dcb5ad905fcfac4cee0d616447cccd059fce6a1d168b0766054659fb29b33867d1fb9
+DIST booleanOperations-0.9.0.tar.gz 165127 BLAKE2B 9f72246afa46c414e3ff9ad23b86da9665a90180fc058ca278b82c1281e798d9d913e496995ca8d45ff948aff5da8a6de26706afdb5e538dee64d7ffe96c7324 SHA512 a63dec9c3a8008825538498b162130624b4d2b9ca64980a23d631601928c5fc6eebdc8f03f19094b7923b008bde6a87b5f21518cb33c8df3fcd41fd84a8ddde9
diff --git a/dev-python/booleanOperations/booleanOperations-0.9.0.ebuild b/dev-python/booleanOperations/booleanOperations-0.9.0.ebuild
new file mode 100644 (file)
index 0000000..0468e6d
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Boolean operations on paths"
+HOMEPAGE="https://github.com/typemytype/booleanOperations"
+SRC_URI="https://github.com/typemytype/booleanOperations/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+BDEPEND=""
+RDEPEND="${DEPEND}
+       >=dev-python/fonttools-4.0.2[${PYTHON_USEDEP}]
+       >=dev-python/pyclipper-1.1.0[${PYTHON_USEDEP}]
+"
+
+src_prepare() {
+       export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
+       distutils-r1_src_prepare
+}
+
+python_test() {
+       esetup.py test
+}