dev-python/snakeoil: version bump to 0.8.1
authorTim Harder <radhermit@gentoo.org>
Fri, 23 Aug 2019 09:22:56 +0000 (03:22 -0600)
committerTim Harder <radhermit@gentoo.org>
Fri, 23 Aug 2019 09:56:58 +0000 (03:56 -0600)
Signed-off-by: Tim Harder <radhermit@gentoo.org>
dev-python/snakeoil/Manifest
dev-python/snakeoil/snakeoil-0.8.1.ebuild [new file with mode: 0644]
dev-python/snakeoil/snakeoil-9999.ebuild

index 8a22ed028c1f017e32db54f800433aad0756ba4f..03fdfd9a251d3db28042cd218bf67a039f9f6e5c 100644 (file)
@@ -1 +1,2 @@
 DIST snakeoil-0.7.5.tar.gz 303270 BLAKE2B 66d00cf50c8efd73d765904b9c7e8ba725caef9608e68f5707ddc09358507fe64214af73b333ec5bee2ef950d8dbad474cb5d9e4412757bc3c82d75909f6fc23 SHA512 b9f6efce2e3f5df83248b1faa84493aa11d8a08935e3991a56daace96e0de39dd5c7d25a69a4394f7ba163de78ed56a2619ef64c33114128fc02052d676a86a5
+DIST snakeoil-0.8.1.tar.gz 296997 BLAKE2B 0eef059c73f6f62ddf67ec3a76d48bc01383f5993236f43cbdef54f6c9e9f818b6065f266df2c8646963f74f8cf3b549ae8e3407cd3a38d38de95d7b84dcfb1b SHA512 70f379d06b000abd193db41fdd720161a22537320a538b6441a9cde86fe0755ec68ab393aa8442e035b134f88e20ddfd4e194961b53f7cfa7a857ec12bf7437c
diff --git a/dev-python/snakeoil/snakeoil-0.8.1.ebuild b/dev-python/snakeoil/snakeoil-0.8.1.ebuild
new file mode 100644 (file)
index 0000000..e85e66b
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_REQ_USE="threads(+)"
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+       EGIT_REPO_URI="https://github.com/pkgcore/snakeoil.git"
+       inherit git-r3
+else
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="misc common functionality and useful optimizations"
+HOMEPAGE="https://github.com/pkgcore/snakeoil"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/pytest-mock[${PYTHON_USEDEP}]
+       )"
+[[ ${PV} == 9999 ]] && DEPEND+=" dev-python/cython[${PYTHON_USEDEP}]"
+
+python_test() {
+       esetup.py test
+}
index 901b625aba59f021ad36e061f9fd88637d20c37d..e85e66b9b7a05e77e91eabce3be60d9d30b8514e 100644 (file)
@@ -11,7 +11,7 @@ if [[ ${PV} == *9999 ]] ; then
        inherit git-r3
 else
        KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
-       SRC_URI="https://github.com/pkgcore/snakeoil/releases/download/v${PV}/${P}.tar.gz"
+       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 fi
 
 DESCRIPTION="misc common functionality and useful optimizations"
@@ -20,6 +20,7 @@ HOMEPAGE="https://github.com/pkgcore/snakeoil"
 LICENSE="BSD"
 SLOT="0"
 IUSE="test"
+RESTRICT="!test? ( test )"
 
 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
        test? (