virtual/libudev: Add support for udev & systemd providing static-libs
authorMichał Górny <mgorny@gentoo.org>
Sat, 26 Oct 2019 18:52:56 +0000 (20:52 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 27 Oct 2019 15:30:41 +0000 (16:30 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
virtual/libudev/libudev-232-r2.ebuild [new file with mode: 0644]

diff --git a/virtual/libudev/libudev-232-r2.ebuild b/virtual/libudev/libudev-232-r2.ebuild
new file mode 100644 (file)
index 0000000..6e8f095
--- /dev/null
@@ -0,0 +1,15 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit multilib-build
+
+DESCRIPTION="Virtual for libudev providers"
+SLOT="0/1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static-libs systemd"
+
+RDEPEND="
+       !systemd? ( >=sys-fs/udev-232:0/0[${MULTILIB_USEDEP},static-libs(-)?] )
+       systemd? ( >=sys-apps/systemd-232:0/2[${MULTILIB_USEDEP},static-libs(-)?] )
+"