app-arch/engrampa: Fix #707298
authorAdam Feldman <NP-Hardass@gentoo.org>
Mon, 6 Apr 2020 20:25:20 +0000 (16:25 -0400)
committerAdam Feldman <NP-Hardass@gentoo.org>
Mon, 6 Apr 2020 22:14:35 +0000 (18:14 -0400)
Closes: https://bugs.gentoo.org/707298
Package-Manager: Portage-2.3.96, Repoman-2.3.21
Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
app-arch/engrampa/engrampa-1.22.3-r1.ebuild [moved from app-arch/engrampa/engrampa-1.22.3.ebuild with 96% similarity]
app-arch/engrampa/files/engrampa-1.22.3-gcc-10-fno-common.patch [new file with mode: 0644]

similarity index 96%
rename from app-arch/engrampa/engrampa-1.22.3.ebuild
rename to app-arch/engrampa/engrampa-1.22.3-r1.ebuild
index d5caa2ad5aac570ca713ded996ffcb805f1bde00..92299844e0fa4be7c4779228493b343489eaa1db 100644 (file)
@@ -45,6 +45,10 @@ src_configure() {
                $(use_enable packagekit)
 }
 
+PATCHES=(
+       "${FILESDIR}/${P}-gcc-10-fno-common.patch"
+)
+
 src_install() {
        mate_src_install
 }
@@ -66,4 +70,3 @@ pkg_postinst() {
        optfeature "Support for unstuff"  app-arch/stuffit
        optfeature "Support for zoo"  app-arch/zoo
 }
-
diff --git a/app-arch/engrampa/files/engrampa-1.22.3-gcc-10-fno-common.patch b/app-arch/engrampa/files/engrampa-1.22.3-gcc-10-fno-common.patch
new file mode 100644 (file)
index 0000000..61e23e0
--- /dev/null
@@ -0,0 +1,22 @@
+From 623bd665371e3afd9dc6fa29f9e1cfe735681358 Mon Sep 17 00:00:00 2001
+From: rbuj <robert.buj@gmail.com>
+Date: Wed, 29 Jan 2020 15:52:44 +0100
+Subject: [PATCH] Fix build using gcc 10 -fno-common flag
+
+---
+ src/main.c | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/src/main.c b/src/main.c
+index 56e75ea0..a9e297dc 100644
+--- a/src/main.c
++++ b/src/main.c
+@@ -33,8 +33,6 @@
+ #include "fr-init.h"
+-gint          ForceDirectoryCreation;
+-
+ static char **remaining_args;
+ static char  *add_to = NULL;
+ static int    add;