dev-vcs/git-cola: Drop 2.11-r1 and 3.2
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 22 Mar 2020 14:10:24 +0000 (15:10 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 22 Mar 2020 14:40:47 +0000 (15:40 +0100)
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-vcs/git-cola/Manifest
dev-vcs/git-cola/files/git-cola-2.10-disable-live-tests.patch [deleted file]
dev-vcs/git-cola/git-cola-2.11-r1.ebuild [deleted file]
dev-vcs/git-cola/git-cola-3.2.ebuild [deleted file]

index 254c0bbae081856798f0b8d4c68e5b251b90b172..2138bce0be7b81e3fcfa8cefd733f719f6857757 100644 (file)
@@ -1,3 +1 @@
-DIST git-cola-2.11.tar.gz 1179769 BLAKE2B db2926b8137b2bb11cc9698b37156d8b0c8f72068061d7d1598b2e3237e44764c2914923103aaaa704babe26cf7a7c16bbe28a61770d98954f776b8ce955658a SHA512 99b865d7a49dcb041e54811141d242386642b5ed6fc12fa7a03431eb9b905cb88d88c4892dc432dd59e8ae3c85f20cc40f4bfb9b6ff002f4e5a4cfc0bdc4c72c
-DIST git-cola-3.2.tar.gz 1208723 BLAKE2B e0375502c7b760a35217c48708e34ba061934f968e6720c3560603b5a76c9474a3a8426f2120ee853a9ac475fc9cbc33ee6ee9a946336e1f28a89d541785c535 SHA512 ca171549dad692088e337efad6f480103a41a1a94f57ae66c15fab3d69e3b18ecc28ac1178886fedd6d969f783e8d5feb4922539c1739ce52c0c0ac59dc941ee
 DIST git-cola-3.5.tar.gz 970155 BLAKE2B ae602d4de0e6fac9d2817100bee8923d8f550d0bb83ddafd806ccdfbd0a77c65bfb60ff03a9399c6b60d5d4683eb6d46ee41eaa43faf2e2ac092b34c9151c999 SHA512 532e24092a72486171345aeb0e7610eb49c4062b64395988c6c4965cac6e9ffaed1268c30a0a525d4d99404f626d9e505a4be148d376994d4326e3ca873e2793
diff --git a/dev-vcs/git-cola/files/git-cola-2.10-disable-live-tests.patch b/dev-vcs/git-cola/files/git-cola-2.10-disable-live-tests.patch
deleted file mode 100644 (file)
index 1f58ea0..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-diff --git a/test/git_test.py b/test/git_test.py
-index 9f812b2..ff7da24 100644
---- a/test/git_test.py
-+++ b/test/git_test.py
-@@ -53,19 +53,6 @@ class GitCommandTest(unittest.TestCase):
-         version = self.git.version()[STDOUT]
-         self.failUnless(version.startswith('git version'))
--    def test_tag(self):
--        """Test running 'git tag'"""
--        tags = self.git.tag()[STDOUT].splitlines()
--        if os.getenv('GIT_COLA_NO_HISTORY', False):
--            return
--        self.failUnless('v1.0.0' in tags)
--
--    def test_show(self):
--        """Test running 'git show'"""
--        oid = 'HEAD'
--        content = self.git.show(oid)[STDOUT]
--        self.failUnless(content.startswith('commit '))
--
-     def test_stdout(self):
-         """Test overflowing the stdout buffer"""
-         # Write to stdout only
diff --git a/dev-vcs/git-cola/git-cola-2.11-r1.ebuild b/dev-vcs/git-cola/git-cola-2.11-r1.ebuild
deleted file mode 100644 (file)
index f0df341..0000000
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-DISTUTILS_SINGLE_IMPL=true
-
-inherit distutils-r1 readme.gentoo-r1 virtualx
-
-DESCRIPTION="The highly caffeinated git GUI"
-HOMEPAGE="https://git-cola.github.io/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-# Since PyQt5 is preferred at runtime if installed, depend on that
-RDEPEND="
-       $(python_gen_cond_dep '
-               dev-python/pyinotify[${PYTHON_MULTI_USEDEP}]
-               dev-python/send2trash[${PYTHON_MULTI_USEDEP}]
-               dev-python/QtPy[gui,${PYTHON_MULTI_USEDEP}]
-               dev-python/PyQt5[gui,network,widgets,${PYTHON_MULTI_USEDEP}]
-       ')
-       dev-vcs/git"
-DEPEND="${RDEPEND}
-       sys-devel/gettext
-       $(python_gen_cond_dep "
-               doc? (
-                       dev-python/sphinx[\${PYTHON_MULTI_USEDEP}]
-                       )
-               test? ( dev-python/nose[\${PYTHON_MULTI_USEDEP}] ${VIRTUALX_DEPEND} )
-       ")
-"
-
-PATCHES=(
-       "${FILESDIR}"/${PN}-2.10-disable-live-tests.patch
-)
-
-python_prepare_all() {
-       # Use system QtPy
-       rm -r qtpy || die
-
-       rm share/git-cola/bin/*askpass* || die
-
-       # remove broken tests
-       rm test/i18n_test.py || die
-
-       # don't install docs into wrong location
-       sed -i -e '/doc/d' setup.py || die
-
-       # fix doc directory reference
-       sed -i \
-               -e "s/'doc', 'git-cola'/'doc', '${PF}'/" \
-               cola/resources.py || die
-
-       # fix ssh-askpass directory reference
-       sed -i -e 's/resources\.share/resources\.prefix/' cola/app.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
-       mydistutilsargs=( --no-vendor-libs )
-}
-
-python_compile_all() {
-       cd share/doc/${PN}/ || die
-       if use doc; then
-               emake all
-       else
-               sed \
-                       -e '/^install:/s:install-html::g' \
-                       -e '/^install:/s:install-man::g' \
-                       -i Makefile || die
-       fi
-}
-
-python_test() {
-       PYTHONPATH="${S}:${S}/build/lib:${PYTHONPATH}" LC_ALL="C" \
-       virtx nosetests --verbose --with-id --with-doctest \
-               --exclude=sphinxtogithub
-}
-
-src_install() {
-       distutils-r1_src_install
-}
-
-python_install_all() {
-       cd share/doc/${PN}/ || die
-       emake \
-               DESTDIR="${D}" \
-               docdir="${EPREFIX}/usr/share/doc/${PF}" \
-               prefix="${EPREFIX}/usr" \
-               install
-
-       python_fix_shebang "${ED}/usr/share/git-cola/bin/git-xbase" "${ED}"/usr/bin/git-cola
-       python_optimize "${ED}/usr/share/git-cola/lib/cola"
-
-       use doc || HTML_DOCS=( "${FILESDIR}"/index.html )
-
-       distutils-r1_python_install_all
-       readme.gentoo_create_doc
-}
diff --git a/dev-vcs/git-cola/git-cola-3.2.ebuild b/dev-vcs/git-cola/git-cola-3.2.ebuild
deleted file mode 100644 (file)
index 1d8dcb0..0000000
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_6 )
-DISTUTILS_SINGLE_IMPL=true
-
-inherit distutils-r1 readme.gentoo-r1 virtualx
-
-DESCRIPTION="The highly caffeinated git GUI"
-HOMEPAGE="https://git-cola.github.io/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       $(python_gen_cond_dep '
-               dev-python/QtPy[gui,${PYTHON_MULTI_USEDEP}]
-               dev-python/numpy[${PYTHON_MULTI_USEDEP}]
-               dev-python/pygments[${PYTHON_MULTI_USEDEP}]
-               dev-python/send2trash[${PYTHON_MULTI_USEDEP}]
-       ')
-       dev-vcs/git"
-DEPEND="${RDEPEND}
-       sys-devel/gettext
-       $(python_gen_cond_dep "
-               doc? (
-                       dev-python/sphinx[\${PYTHON_MULTI_USEDEP}]
-                       )
-               test? (
-                       ${VIRTUALX_DEPEND}
-                       dev-python/nose[\${PYTHON_MULTI_USEDEP}]
-                       dev-python/mock[\${PYTHON_MULTI_USEDEP}]
-                       )
-       ")"
-
-python_prepare_all() {
-       # make sure that tests also use the system provided QtPy
-       rm -r qtpy || die
-
-       rm share/git-cola/bin/*askpass* || die
-
-       # don't install docs into wrong location
-       sed -i -e '/doc/d' setup.py || die
-
-       # fix doc directory reference
-       sed -i \
-               -e "s/'doc', 'git-cola'/'doc', '${PF}'/" \
-               cola/resources.py || die
-
-       # fix ssh-askpass directory reference
-       sed -i -e 's/resources\.share/resources\.prefix/' cola/app.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
-       mydistutilsargs=( --no-vendor-libs )
-}
-
-python_compile_all() {
-       cd share/doc/${PN}/ || die
-       if use doc ; then
-               emake all
-       else
-               sed \
-                       -e '/^install:/s:install-html::g' \
-                       -e '/^install:/s:install-man::g' \
-                       -i Makefile || die
-       fi
-}
-
-python_test() {
-       PYTHONPATH="${S}:${S}/build/lib:${PYTHONPATH}" LC_ALL="en_US.utf8" \
-       virtx nosetests --verbose --with-id --with-doctest \
-               --exclude=sphinxtogithub
-}
-
-src_install() {
-       distutils-r1_src_install
-}
-
-python_install_all() {
-       cd share/doc/${PN}/ || die
-       emake \
-               DESTDIR="${D}" \
-               docdir="${EPREFIX}/usr/share/doc/${PF}" \
-               prefix="${EPREFIX}/usr" \
-               install
-
-       python_fix_shebang "${ED}/usr/share/git-cola/bin/git-xbase" "${ED}"/usr/bin/git-cola
-       python_optimize "${ED}/usr/share/git-cola/lib/cola"
-
-       use doc || HTML_DOCS=( "${FILESDIR}"/index.html )
-
-       distutils-r1_python_install_all
-       readme.gentoo_create_doc
-}