dev-python/retrying: Add python3.5 support
authorJustin Lecher <jlec@gentoo.org>
Sun, 11 Oct 2015 09:55:01 +0000 (11:55 +0200)
committerJustin Lecher <jlec@gentoo.org>
Sun, 11 Oct 2015 11:24:29 +0000 (13:24 +0200)
Package-Manager: portage-2.2.23
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/retrying/retrying-1.3.2.ebuild
dev-python/retrying/retrying-1.3.3-r1.ebuild [new file with mode: 0644]
dev-python/retrying/retrying-1.3.3.ebuild

index 29f677cb591f6b6f3b298dc21bbb77781b5301ec..232be29be872d293ac1a791dfda9efe8864be104 100644 (file)
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
 
 inherit distutils-r1
 
-DESCRIPTION="Retrying is a general-purpose retrying library."
+DESCRIPTION="General-purpose retrying library"
 HOMEPAGE="https://github.com/rholder/retrying"
 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 
diff --git a/dev-python/retrying/retrying-1.3.3-r1.ebuild b/dev-python/retrying/retrying-1.3.3-r1.ebuild
new file mode 100644 (file)
index 0000000..7775740
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="General-purpose retrying library"
+HOMEPAGE="https://github.com/rholder/retrying"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND="
+       >=dev-python/six-1.7.0[${PYTHON_USEDEP}]
+"
index d4bb7e0664875f981372863fdd5d68299d40e776..ab990eee69a0622c386a2e97cea1ae6ba48f4fad 100644 (file)
@@ -8,7 +8,7 @@ PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
 
 inherit distutils-r1
 
-DESCRIPTION="Retrying is a general-purpose retrying library."
+DESCRIPTION="General-purpose retrying library"
 HOMEPAGE="https://github.com/rholder/retrying"
 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"