Bump to googleearth-4; fixes bug 160849
authorCharlie Shepherd <masterdriverz@gentoo.org>
Fri, 12 Jan 2007 19:29:38 +0000 (19:29 +0000)
committerCharlie Shepherd <masterdriverz@gentoo.org>
Fri, 12 Jan 2007 19:29:38 +0000 (19:29 +0000)
Package-Manager: portage-2.1.2_rc4-r3

x11-misc/googleearth/ChangeLog
x11-misc/googleearth/files/digest-googleearth-4 [new file with mode: 0644]
x11-misc/googleearth/googleearth-4.ebuild [new file with mode: 0644]

index bcc77289de44e91729ab3614c1d85f73656ee880..11eeae191630e7faeb40cd358638298e5f674014 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for x11-misc/googleearth
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/googleearth/ChangeLog,v 1.20 2007/01/08 07:50:25 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/googleearth/ChangeLog,v 1.21 2007/01/12 19:29:38 masterdriverz Exp $
+
+*googleearth-4 (12 Jan 2007)
+
+  12 Jan 2007; Charlie Shepherd <masterdriverz@gentoo.org>
+  -googleearth-4_beta.ebuild, +googleearth-4.ebuild:
+  Bump to googleearth-4; fixes bug 160849
 
   08 Jan 2007; <genstef@gentoo.org> googleearth-4_beta.ebuild:
   Fix troubles with newer ati drivers thanks to anarchy in bug 158701
diff --git a/x11-misc/googleearth/files/digest-googleearth-4 b/x11-misc/googleearth/files/digest-googleearth-4
new file mode 100644 (file)
index 0000000..338a355
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 0a97dfa4b22d561799a0131822293fad GoogleEarthLinux.bin 21607720
+RMD160 fed3a3cb81f963dcf1dde8e386640fd08a1ce9f8 GoogleEarthLinux.bin 21607720
+SHA256 369046688de0a749ddce2aa444c6cd5c8b0a0fbd23f16626e241e3df6f8e0d76 GoogleEarthLinux.bin 21607720
diff --git a/x11-misc/googleearth/googleearth-4.ebuild b/x11-misc/googleearth/googleearth-4.ebuild
new file mode 100644 (file)
index 0000000..ece684e
--- /dev/null
@@ -0,0 +1,85 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/googleearth/googleearth-4.ebuild,v 1.1 2007/01/12 19:29:38 masterdriverz Exp $
+
+inherit eutils fdo-mime
+
+DESCRIPTION="A 3D interface to the planet"
+HOMEPAGE="http://earth.google.com/"
+SRC_URI="http://dl.google.com/earth/GE4/GoogleEarthLinux.bin"
+
+LICENSE="googleearth MIT X11 SGI-B-1.1 openssl as-is ZLIB"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+RESTRICT="mirror strip"
+IUSE=""
+
+RDEPEND="x86? (
+       media-libs/fontconfig
+       media-libs/freetype
+       virtual/opengl
+       || ( ( x11-libs/libICE
+               x11-libs/libSM
+               x11-libs/libX11
+               x11-libs/libXcursor
+               x11-libs/libXext
+               x11-libs/libXft
+               x11-libs/libXrender )
+               <virtual/x11-7.0 ) )
+       amd64? (
+       app-emulation/emul-linux-x86-xlibs
+       app-emulation/emul-linux-x86-baselibs
+       || (
+               >=app-emulation/emul-linux-x86-xlibs-7.0
+               x11-drivers/nvidia-drivers
+               x11-drivers/nvidia-legacy-drivers
+               <x11-drivers/ati-drivers-8.28.8 ) )
+       media-fonts/ttf-bitstream-vera"
+
+S="${WORKDIR}"
+
+src_unpack() {
+       unpack_makeself
+       # make the postinst scripts behave
+       sed -i -e 's:$SETUP_INSTALLPATH/::' \
+               -e "s:^xdg-mime:linux/xdg/xdg-mime:" \
+               -e "s:^xdg-menu:linux/xdg/xdg-menu:" \
+               -e "s: --user: --system:" \
+               -e 's:$SETUP_INSTALLPATH:1:' postinstall.sh
+       sed -i -e "s:/usr:${D}/usr:g" \
+               -e "s:^detectDE$::" \
+               -e 's:-x $x/update-mime:-d nonexis:' \
+               -e 's:-x $x/update-desktop:-d nonexis:' linux/xdg/xdg-m{ime,enu}
+}
+
+src_install() {
+       make_wrapper ${PN} ./${PN} /opt/${PN} . || die "make_wrapper failed"
+
+       unset XDG_DATA_DIRS
+       dodir /usr/share/{appl{ications,nk},gnome/apps,mime/packages}
+       ./postinstall.sh
+       doicon ${PN}-icon.png
+
+       dodoc README.linux
+
+       cd bin
+       tar xf ${WORKDIR}/${PN}-linux-x86.tar
+       exeinto /opt/${PN}
+       doexe *
+
+       cd ${D}/opt/${PN}
+       tar xf ${WORKDIR}/${PN}-data.tar
+
+       cd ${D}
+       # mime magic for gnome by Ed Catmur in bug 141371
+       epatch ${FILESDIR}/mime-magic.patch
+
+       # make sure we install with correct permissions
+       fowners -R root:root /opt/${PN}
+       fperms -R a-x,a+X /opt/googleearth/{xml,res{,ources}}
+}
+
+pkg_postinst() {
+       fdo-mime_desktop_database_update
+       fdo-mime_mime_database_update
+}