app-crypt/osslsigncode: Version bump
authorHanno <hanno@gentoo.org>
Sun, 2 Dec 2018 08:17:00 +0000 (09:17 +0100)
committerHanno <hanno@gentoo.org>
Sun, 2 Dec 2018 08:17:00 +0000 (09:17 +0100)
Signed-off-by: Hanno Boeck <hanno@gentoo.org>
Package-Manager: Portage-2.3.52, Repoman-2.3.12

app-crypt/osslsigncode/Manifest
app-crypt/osslsigncode/osslsigncode-1.7.1.ebuild [new file with mode: 0644]

index e0f38f1ced9f6bad32898b744071868dede54d20..f2682eea0a823996cdc08a1f581c18d5d09a6be2 100644 (file)
@@ -1 +1,2 @@
 DIST osslsigncode-1.4.tar.gz 96512 BLAKE2B 8325153d16b7ad5d0701daf3d5d446bef498aaf45b88a78d5472d86c0899a73bff2350c224f9f3e35475d5dd72792fe24328f4710d25984ae23c5f83c6fef967 SHA512 89f82b5cbab5952b7bb0b1a3ea230db0c38d171924e5150e9cd157158e52d312cc10093ac719265d03a097f995bd3a438fe874c50263659859c625482ef0239f
+DIST osslsigncode-1.7.1.tar.gz 127631 BLAKE2B f0ced06a33968f03558e189fc9ed2340dba2cdfe823422c760d62476446646f198aed1a95f99734f80e7ec71d23cd286a23e68953f7e432a9a6ff048c76cae63 SHA512 cc5a7e0c5baa2a98db93f1d2cc9d86e732e2a8a55fc20bf8e6aa67e2120af37c6be857dfe4b8eb8c82fd40604dbb3c845190b59c7e6b4147f06b710a256b877f
diff --git a/app-crypt/osslsigncode/osslsigncode-1.7.1.ebuild b/app-crypt/osslsigncode/osslsigncode-1.7.1.ebuild
new file mode 100644 (file)
index 0000000..4ea2473
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="Platform-independent tool for Authenticode signing of EXE/CAB files"
+HOMEPAGE="https://sourceforge.net/projects/osslsigncode"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="curl libressl"
+
+RDEPEND="
+       !libressl? ( dev-libs/openssl:0= )
+       libressl? ( dev-libs/libressl:0= )
+       curl? ( net-misc/curl )"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+src_configure() {
+       econf $(use_with curl)
+}