dev-python/weakrefmethod: initial add
authorMatthew Thode <prometheanfire@gentoo.org>
Mon, 27 Feb 2017 05:13:58 +0000 (23:13 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Mon, 27 Feb 2017 05:45:36 +0000 (23:45 -0600)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-python/weakrefmethod/Manifest [new file with mode: 0644]
dev-python/weakrefmethod/metadata.xml [new file with mode: 0644]
dev-python/weakrefmethod/weakrefmethod-1.0.3.ebuild [new file with mode: 0644]

diff --git a/dev-python/weakrefmethod/Manifest b/dev-python/weakrefmethod/Manifest
new file mode 100644 (file)
index 0000000..f259b28
--- /dev/null
@@ -0,0 +1 @@
+DIST weakrefmethod-1.0.3.tar.gz 7472 SHA256 37bc1fbb5575acf82172d4eb7b6fc4412d77d5a1d70dff2c1f8a4574301cda66 SHA512 c68dc806904eb954319984003506eb9b552005ce04722c6a3eb123ecde8f4413f9f9d114f0923c6f6ae2e25b4dbaf8c225c070a1720a6563cf1517f2411a60d5 WHIRLPOOL f34fd902a17cc134952ec51fb1025a78e288349d7f36cea9ab24f5155dd2112ee83416563c8f4cf60daf5129c6531dbec512e4bb5b56e52950b6a10317c2f35c
diff --git a/dev-python/weakrefmethod/metadata.xml b/dev-python/weakrefmethod/metadata.xml
new file mode 100644 (file)
index 0000000..a40778a
--- /dev/null
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>prometheanfire@gentoo.org</email>
+               <name>Matthew Thode</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>openstack@gentoo.org</email>
+               <name>Openstack</name>
+       </maintainer>
+       <longdescription lang="en">
+       Backport of WeakMethod from Python 3.4 to Python 2.6+
+       </longdescription>
+       <upstream>
+               <remote-id type="pypi">weakrefmethod</remote-id>
+               <remote-id type="github">twang817/weakrefmethod</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/dev-python/weakrefmethod/weakrefmethod-1.0.3.ebuild b/dev-python/weakrefmethod/weakrefmethod-1.0.3.ebuild
new file mode 100644 (file)
index 0000000..3de8b7a
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Backport of WeakMethod from Python 3.4 to Python 2.6+"
+HOMEPAGE="https://github.com/rholder/retrying"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND=""