dev-libs/libflatarray: Drop old
authorKurt Kanzenbach <kurt@kmk-computers.de>
Thu, 26 Mar 2020 15:34:12 +0000 (16:34 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Sat, 28 Mar 2020 14:21:16 +0000 (16:21 +0200)
These were needed to support an old version of libgeodecomp. No reason to keep
them around.

Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-libs/libflatarray/Manifest
dev-libs/libflatarray/libflatarray-0.2.0-r1.ebuild [deleted file]
dev-libs/libflatarray/libflatarray-0.3.0-r1.ebuild [deleted file]

index 0548310a4f16219d31e27f295742be076e16aadb..436bbecce6208d8e35683500b1f1212336909796 100644 (file)
@@ -1,3 +1 @@
-DIST libflatarray-0.2.0.tar.bz2 34193 BLAKE2B 8f409b097a0dfe037e9fdd1f8ed3b0ba86ef9ab816219b9357d119afa1c7236c0a467d9705fd5050ccbdc54ee40b811d2daee0a697f8ba720f037294d0305d52 SHA512 96050c08479429baf22a9694ca7354e1ab4fa892976d4098419e2863cac8e21aec586116a1702a5050753febd9b9321a14fc4da5d6487cf75a574562ec4d4647
-DIST libflatarray-0.3.0.tar.bz2 104544 BLAKE2B 9ac490a526fbd71478ac569538bad28e01a1a91bd71d37e85bf89181e856e79b2dec6af5415f238e5f72fbbe57cda59ee87ebd79cd273887061e2bbb93a7ce31 SHA512 c58339cdadf98f552d2f1b440a293c48923f32fc43a5a06ee8b8a40835a5f6c21514f7a9efa0ff23930ab9fdda8d4389641ec83c589e1982dbf5a3f75d2ffd37
 DIST libflatarray-0.4.0_pre20200314.tar.gz 165804 BLAKE2B 593e26b4c67ca67143ac9fdfca697700ae4caff807bca0b50d7a2de05ad8dadb79c98f9db39b728fdf098cd8e948c99963d11cf95bbc31b6c0f485e81d9736e8 SHA512 3f78c0db04e3de637fd8ed938c2d4d88d1eb270fc6a95f2d1b0909c4a6df40720e77c2aedac5ba38be32f703600a075107000ba028b38739b4206b7498f66955
diff --git a/dev-libs/libflatarray/libflatarray-0.2.0-r1.ebuild b/dev-libs/libflatarray/libflatarray-0.2.0-r1.ebuild
deleted file mode 100644 (file)
index 726b836..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake cuda
-
-DESCRIPTION="Struct of arrays library with object oriented interface for C++"
-HOMEPAGE="
-       http://www.libgeodecomp.org/libflatarray.html
-       https://github.com/STEllAR-GROUP/libflatarray"
-SRC_URI="http://www.libgeodecomp.org/archive/${P}.tar.bz2"
-
-LICENSE="Boost-1.0"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="cuda examples"
-RESTRICT="test"
-
-DEPEND=">=dev-libs/boost-1.48
-       cuda? ( dev-util/nvidia-cuda-toolkit )"
-
-src_prepare() {
-       cmake_src_prepare
-       use cuda && cuda_src_prepare
-}
-
-src_configure() {
-       local mycmakeargs=(
-               -DWITH_CUDA=$(usex cuda)
-       )
-       cmake_src_configure
-}
-
-src_install() {
-       cmake_src_install
-
-       if use examples; then
-               docompress -x /usr/share/doc/${PF}
-               dodoc -r examples/
-               dodoc -r "${WORKDIR}"/${P}_build/examples/
-               find "${ED}"/usr/share/doc/${PF} -iname "*cmake*" -exec rm -r {} + || die
-       fi
-}
diff --git a/dev-libs/libflatarray/libflatarray-0.3.0-r1.ebuild b/dev-libs/libflatarray/libflatarray-0.3.0-r1.ebuild
deleted file mode 100644 (file)
index 91d438f..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake cuda
-
-DESCRIPTION="Struct of arrays library with object oriented interface for C++"
-HOMEPAGE="
-       http://www.libgeodecomp.org/libflatarray.html
-       https://github.com/STEllAR-GROUP/libflatarray"
-SRC_URI="http://www.libgeodecomp.org/archive/${P}.tar.bz2"
-
-LICENSE="Boost-1.0"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="cuda examples test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
-       cuda? ( dev-util/nvidia-cuda-toolkit )"
-
-src_prepare() {
-       cmake_src_prepare
-       use cuda && cuda_src_prepare
-}
-
-src_configure() {
-       local mycmakeargs=(
-               -DWITH_CUDA=$(usex cuda)
-       )
-       cmake_src_configure
-}
-
-src_install() {
-       cmake_src_install
-
-       if use examples; then
-               docompress -x /usr/share/doc/${PF}
-               dodoc -r examples/
-               dodoc -r "${WORKDIR}"/${P}_build/examples/
-               find "${ED}"/usr/share/doc/${PF} -iname "*cmake*" -exec rm -r {} + || die
-       fi
-}
-
-src_test() {
-       cmake_build check
-}