app-office/libreoffice: Update live ebuild
authorNils Freydank <holgersson@posteo.de>
Mon, 2 Mar 2020 22:24:57 +0000 (23:24 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Mon, 16 Mar 2020 21:25:45 +0000 (22:25 +0100)
Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Nils Freydank <holgersson@posteo.de>
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
app-office/libreoffice/libreoffice-9999.ebuild

index b3fa65e1997829940bdd88849163dbb27b9ba8ba..ccf7d012c40b9ab9a5b5b9d51d175fae8cbdf4ba 100644 (file)
@@ -53,6 +53,8 @@ ADDONS_SRC=(
        "libreoffice_extensions_scripting-javascript? ( ${ADDONS_URI}/35c94d2df8893241173de1d16b6034c0-swingExSrc.zip )"
        # not packageable
        "odk? ( http://download.go-oo.org/extern/185d60944ea767075d27247c3162b3bc-unowinreg.dll )"
+       # QR code generating library for >=libreoffice-6.4
+       "https://dev-www.libreoffice.org/src/QR-Code-generator-1.4.0.tar.gz"
 )
 SRC_URI+=" ${ADDONS_SRC[*]}"
 
@@ -78,6 +80,7 @@ RESTRICT="!test? ( test )"
 
 LICENSE="|| ( LGPL-3 MPL-1.1 )"
 SLOT="0"
+
 [[ ${MY_PV} == *9999* ]] || \
 KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
 
@@ -120,7 +123,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
        dev-libs/icu:=
        dev-libs/libassuan
        dev-libs/libgpg-error
-       >=dev-libs/liborcus-0.14.0
+       >=dev-libs/liborcus-0.15.0
        dev-libs/librevenge
        dev-libs/libxml2
        dev-libs/libxslt
@@ -153,9 +156,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
        x11-libs/libXrandr
        x11-libs/libXrender
        accessibility? (
-               $(python_gen_cond_dep '
-                       dev-python/lxml[${PYTHON_MULTI_USEDEP}]
-               ')
+               $(python_gen_cond_dep 'dev-python/lxml[${PYTHON_MULTI_USEDEP}]')
        )
        bluetooth? (
                dev-libs/glib:2
@@ -210,7 +211,7 @@ DEPEND="${COMMON_DEPEND}
        dev-perl/Archive-Zip
        >=dev-util/cppunit-1.14.0
        >=dev-util/gperf-3.1
-       >=dev-util/mdds-1.4.1:1=
+       >=dev-util/mdds-1.5.0:1=
        media-libs/glm
        sys-devel/ucpp
        x11-base/xorg-proto
@@ -272,12 +273,6 @@ pkg_pretend() {
 
        use java || ewarn "Without java, several wizards are not going to be available."
 
-       if has_version "<app-office/libreoffice-5.3.0[firebird]"; then
-               ewarn "Firebird has been upgraded to version 3. It is unable to read back Firebird 2.5 data, so"
-               ewarn "embedded firebird odb files created in LibreOffice pre-5.3 can't be opened with this version."
-               ewarn "See also: https://wiki.documentfoundation.org/ReleaseNotes/5.3#Base"
-       fi
-
        [[ ${MERGE_TYPE} != binary ]] && _check_reqs pkg_pretend
 }
 
@@ -389,6 +384,7 @@ src_configure() {
        # --without-system-sane: just sane.h header that is used for scan in writer,
        #   not linked or anything else, worthless to depend on
        # --disable-pdfium: not yet packaged
+       # --without-system-qrencode: has no real build system and LO is the only user
        local myeconfargs=(
                --with-system-dicts
                --with-system-epoxy
@@ -408,8 +404,6 @@ src_configure() {
                --disable-ccache
                --disable-epm
                --disable-fetch-external
-               --disable-gstreamer-0-10
-               --disable-gtk
                --disable-gtk3-kde5
                --disable-online-update
                --disable-openssl
@@ -434,6 +428,7 @@ src_configure() {
                --without-helppack-integration
                --with-system-gpgmepp
                --without-system-sane
+               --without-system-qrcodegen
                $(use_enable bluetooth sdremote-bluetooth)
                $(use_enable coinmp)
                $(use_enable cups)
@@ -516,7 +511,7 @@ src_test() {
 
 src_install() {
        # This is not Makefile so no buildserver
-       make DESTDIR="${D}" distro-pack-install -o build -o check || die
+       emake DESTDIR="${D}" distro-pack-install -o build -o check
 
        # bug 593514
        if use gtk; then