dev-lang/spidermonkey:45 - hack to force copy instead of symlink
authorIan Stakenvicius <axs@gentoo.org>
Tue, 28 Feb 2017 19:09:15 +0000 (14:09 -0500)
committerIan Stakenvicius <axs@gentoo.org>
Tue, 28 Feb 2017 19:10:03 +0000 (14:10 -0500)
This commit implements a bad hack that overrides the build system's
determination that headers should be installed as symlinks by sed'ing a
buildsystem-generated file after configure completes.  It's not ideal
but it will allow the package to be unmasked.

Package-Manager: portage-2.3.3

dev-lang/spidermonkey/spidermonkey-45.0.2.ebuild
profiles/package.mask

index 5eb8463c609cf99595e9d17add287ace8b78fb84..aa14536766ee164de9e399dbd2bb1acbba35e47a 100644 (file)
@@ -72,6 +72,12 @@ src_configure() {
                $(use_enable jit ion) \
                $(use_enable static-libs static) \
                $(use_enable test tests)
+
+       # An unfortunate hack to undo header install symlinking, but
+       # necessary until the function that generates this file can be
+       # determined and fixed
+       sed -i -e 's/^1/2/' \
+               "${BUILDDIR}"/_build_manifests/install/dist_include || die
 }
 
 cross_make() {
index 7189e77509f8a44a052dd4e98a63b2dda667f639..de5db9debb5a139b9b0175a7913773396427ce98 100644 (file)
 
 #--- END OF EXAMPLES ---
 
-# Ian Stakenvicius <axs@gentoo.org> (28 Feb 2017)
-# Installs symlinks to ${S} instead of copies of files,
-# will unmask once fixed
-dev-lang/spidermonkey:45
-
 # Matt Turner <mattst88@gentoo.org> (26 Feb 2017)
 # Integrated into xorg-server since 1.17. Removal in 30 days.
 # Bug #611058