dev-python/elementpath: Port to py39
authorMichał Górny <mgorny@gentoo.org>
Tue, 26 May 2020 10:44:40 +0000 (12:44 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 26 May 2020 12:58:23 +0000 (14:58 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/elementpath/elementpath-1.4.5.ebuild

index fa02bf8a9d4af1289fbcd959917e2b261a9716e6..dd056a9406a414a38b001772b3a1f4d311f90bd5 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
 inherit distutils-r1
 
 DESCRIPTION="XPath 1.0/2.0 parsers and selectors for ElementTree and lxml"
@@ -18,7 +18,6 @@ IUSE="test"
 RESTRICT="!test? ( test )"
 
 BDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
                dev-python/lxml[${PYTHON_USEDEP}]
                dev-python/xmlschema[${PYTHON_USEDEP}]