gnome-extra/gnome-user-docs: bump to 3.34.1
authorMart Raudsepp <leio@gentoo.org>
Tue, 17 Mar 2020 18:51:14 +0000 (20:51 +0200)
committerMart Raudsepp <leio@gentoo.org>
Tue, 17 Mar 2020 19:05:20 +0000 (21:05 +0200)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
gnome-extra/gnome-user-docs/Manifest
gnome-extra/gnome-user-docs/gnome-user-docs-3.34.1.ebuild [new file with mode: 0644]

index b553ba4840115ea0b87fc2a8fe98f02d69eeb5c6..400bd9e94458e8db44ac3d93b103d0e4a6be37e4 100644 (file)
@@ -1 +1,2 @@
 DIST gnome-user-docs-3.32.3.tar.xz 15861776 BLAKE2B cc4a73319ced02d7e087d2e9e1a70db22fbac3f9bebc34deb029c913573b34b58977007fe274841c6b61d05c3e169f959425c28846f1c741944f61c1c01b53a2 SHA512 4b62be1812ae67283281ec9d5dfd7e694dd01c04ede949cef76ab42dde72b74f90a67bc359e86700f515ddff920fb81a40e91acef56c85b40b49ce0505c1f7ed
+DIST gnome-user-docs-3.34.1.tar.xz 15983924 BLAKE2B 5e9c07cb1e5d33b4fc220a00e679e26d804963fa7ee8d42d4e805e8abaa1e8717028c03815ff3bd82f81d3a61fcf38b258940ec88ef2e9b1fbdf4df6d94bb8d0 SHA512 f9e65f4d0770ce97493f2eaa6b7743575e3bca3d816d0cd06ee35af99016722631086502450db5900693527a71bec9d65c97829c1486b6aff4a137a7f6016baf
diff --git a/gnome-extra/gnome-user-docs/gnome-user-docs-3.34.1.ebuild b/gnome-extra/gnome-user-docs/gnome-user-docs-3.34.1.ebuild
new file mode 100644 (file)
index 0000000..1c83d24
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="GNOME end user documentation"
+HOMEPAGE="https://git.gnome.org/browse/gnome-user-docs"
+
+LICENSE="CC-BY-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="
+       test? ( dev-libs/libxml2 )
+"
+# eautoreconf requires:
+#      app-text/yelp-tools
+# rebuilding translations requires:
+#      app-text/yelp-tools
+#      dev-util/gettext
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip
+       !test? ( test )"
+
+src_configure() {
+       # itstool is only needed for rebuilding translations
+       # xmllint is only needed for tests
+       gnome2_src_configure \
+               $(usex test "" XMLLINT=$(type -P true)) \
+               ITSTOOL=$(type -P true)
+}
+
+src_compile() {
+       # Do not compile; "make all" with unset LINGUAS rebuilds all translations,
+       # which can take > 2 hours on a Core i7.
+       return
+}