dev-perl/CGI-Session: -r bump for EAPI7 & License fixes
authorKent Fredric <kentnl@gentoo.org>
Thu, 7 May 2020 09:00:08 +0000 (21:00 +1200)
committerKent Fredric <kentnl@gentoo.org>
Thu, 7 May 2020 09:01:04 +0000 (21:01 +1200)
- EAPI7
- Fix missing entries in metadata.xml
- Correct LICENSE as best possible re bug #721398

Bug: https://bugs.gentoo.org/721398
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/CGI-Session/CGI-Session-4.480.0-r3.ebuild [new file with mode: 0644]
dev-perl/CGI-Session/metadata.xml

diff --git a/dev-perl/CGI-Session/CGI-Session-4.480.0-r3.ebuild b/dev-perl/CGI-Session/CGI-Session-4.480.0-r3.ebuild
new file mode 100644 (file)
index 0000000..326cb87
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=MARKSTOS
+DIST_VERSION=4.48
+inherit perl-module
+
+DESCRIPTION="persistent session data in CGI applications"
+# Bug: https://bugs.gentoo.org/show_bug.cgi?id=721398
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       virtual/perl-Digest-MD5
+       virtual/perl-Scalar-List-Utils
+       >=dev-perl/CGI-3.26
+"
+DEPEND="
+       dev-perl/Module-Build
+"
+BDEPEND="${RDEPEND}
+       >=dev-perl/Module-Build-0.380.0
+       test? (
+               virtual/perl-Test-Simple
+               dev-perl/CGI-Simple
+       )
+"
index 648b4fdd2d865ca6a55c23d02e8b0d54825c4338..ac5cd06c60ea10b44bae51630911e1d3aeef4b13 100644 (file)
@@ -23,6 +23,7 @@
     <remote-id type="cpan-module">CGI::Session::Serialize::freezethaw</remote-id>
     <remote-id type="cpan-module">CGI::Session::Serialize::storable</remote-id>
     <remote-id type="cpan-module">CGI::Session::Test::Default</remote-id>
+    <remote-id type="cpan-module">CGI::Session::Test::SimpleObjectClass</remote-id>
     <remote-id type="cpan-module">CGI::Session::Tutorial</remote-id>
     <remote-id type="cpan-module">OverloadedClass</remote-id>
   </upstream>