dev-python/numpy: fix build with recent distutils-r1 change
authorMike Gilbert <floppym@gentoo.org>
Thu, 16 Apr 2020 17:43:42 +0000 (13:43 -0400)
committerMike Gilbert <floppym@gentoo.org>
Thu, 16 Apr 2020 17:43:42 +0000 (13:43 -0400)
Closes: https://bugs.gentoo.org/717706
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
dev-python/numpy/files/numpy-1.16.5-setup.py-install-skip-build-fails.patch [new file with mode: 0644]
dev-python/numpy/numpy-1.16.5.ebuild

diff --git a/dev-python/numpy/files/numpy-1.16.5-setup.py-install-skip-build-fails.patch b/dev-python/numpy/files/numpy-1.16.5-setup.py-install-skip-build-fails.patch
new file mode 100644 (file)
index 0000000..aa141de
--- /dev/null
@@ -0,0 +1,23 @@
+From b8e741c66f71071c3406e592e1537570731bcb35 Mon Sep 17 00:00:00 2001
+From: mattip <matti.picus@gmail.com>
+Date: Sun, 26 May 2019 08:55:53 +0300
+Subject: [PATCH] BUG: setup.py install --skip-build fails
+
+---
+ numpy/distutils/command/install_clib.py | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/numpy/distutils/command/install_clib.py b/numpy/distutils/command/install_clib.py
+index 662aa00bda9..6a73f7e3308 100644
+--- a/numpy/distutils/command/install_clib.py
++++ b/numpy/distutils/command/install_clib.py
+@@ -19,6 +19,9 @@ def finalize_options(self):
+     def run (self):
+         build_clib_cmd = get_cmd("build_clib")
++        if not build_clib_cmd.build_clib:
++            # can happen if the user specified `--skip-build`
++            build_clib_cmd.finalize_options()
+         build_dir = build_clib_cmd.build_clib
+         # We need the compiler to get the library name -> filename association
index c76742829cb8c7c79f0d611cd74b614e51f5d505..a0a04127fa08f478800ae154f768d4131d2ad56a 100644 (file)
@@ -41,6 +41,7 @@ BDEPEND="app-arch/unzip
 
 PATCHES=(
        "${FILESDIR}"/${PN}-1.15.4-no-hardcode-blas.patch
+       "${FILESDIR}"/numpy-1.16.5-setup.py-install-skip-build-fails.patch
 )
 
 src_unpack() {