dev-python/ipaddress: Bump to version 1.0.18
authorLars Wendler <polynomial-c@gentoo.org>
Mon, 23 Jan 2017 02:41:31 +0000 (03:41 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Mon, 23 Jan 2017 03:37:49 +0000 (04:37 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-python/ipaddress/Manifest
dev-python/ipaddress/ipaddress-1.0.18.ebuild [new file with mode: 0644]

index e7c9a36f0811a52ffc6c9f35b9188dc72c93e9d3..e3b6289cd4aa4e8132061aa580eee8c9ccba4595 100644 (file)
@@ -1,3 +1,4 @@
 DIST ipaddress-1.0.14.tar.gz 30429 SHA256 226f4be44c6cb64055e23060848266f51f329813baae28b53dc50e93488b3b3e SHA512 fb33b484ca435f4e8817c735a1084f2fa749abca4643a10be644003fdb73cc9205fc28f484ef96d2db90e8b27d8a238d1d7cf20140f7942e39be12c7524e8d6f WHIRLPOOL 30e21d5b7568125575fecd0f8cac4172713c029faa81f88cd2a6111b47da1fb3bea9305a9311ce1a7b2795e9d54b58f2cbef1e5b66f355b8c91633ead0836d04
 DIST ipaddress-1.0.16.tar.gz 31765 SHA256 5a3182b322a706525c46282ca6f064d27a02cffbd449f9f47416f1dc96aa71b0 SHA512 50baf15f185b039037eef7b047d5a0ffbe1b335d2d94c218b6a2012ae1ba89c5e5c4f64667d8a623e4e4e7598d90c8a7caa8327ea4c155260ab90384f86a6c89 WHIRLPOOL de25e35f36e33a0b490ba51fb9abe8f2e81b09ba3e2b8d496f3e4fe1b29e243da928a0ce8ea837cee39c49d3ba60fddbe143a7eee1642baf1e97f10b5bb3785b
 DIST ipaddress-1.0.17.tar.gz 32434 SHA256 3a21c5a15f433710aaa26f1ae174b615973a25182006ae7f9c26de151cd51716 SHA512 c9f7c7226fd28a1b3905139713c2269b4bdbe5bc1b8e44ab8edd56c0cd2b6938577a66fce139ecce06398de89321097ac672bff2d1618ca2f3b917c15553f50d WHIRLPOOL 6d2f0be2f7db20f94fd83ac344fad17196c2351456641ce01ec116d80d657f37e98ae8df78e5bbb716bc95c598d16c49269cd35845cf44c26da88963f24d59a2
+DIST ipaddress-1.0.18.tar.gz 32475 SHA256 5d8534c8e185f2d8a1fda1ef73f2c8f4b23264e8e30063feeb9511d492a413e1 SHA512 7d1c8cf67db5b55a872783390ca214bb39e243d313311674afe10008e86638838bef5f9e6d703803bdcfde6d27520b1fc19d0adb19d482e27a327fb735aa0312 WHIRLPOOL 0cbe1230da55740e8486590a27f491c79b5c005e75c9b70b990168b600981f87e6167859ac2a4a00f21885ae6ffd86bd06a9aa8a445a7d595c2818dee8d239cc
diff --git a/dev-python/ipaddress/ipaddress-1.0.18.ebuild b/dev-python/ipaddress/ipaddress-1.0.18.ebuild
new file mode 100644 (file)
index 0000000..439395f
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="IPv4/IPv6 manipulation library, backport of the ipaddress module"
+HOMEPAGE="https://github.com/phihag/ipaddress"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="PSF-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+       "${PYTHON}" test_ipaddress.py || die
+}