sys-devel/llvm: Add dependency on binutils-libs on latest ~arch
authorMichał Górny <mgorny@gentoo.org>
Thu, 1 Oct 2015 20:11:47 +0000 (22:11 +0200)
committerMichał Górny <mgorny@gentoo.org>
Thu, 1 Oct 2015 20:11:47 +0000 (22:11 +0200)
Try to fix the issue of llvm being unable to find binutils headers
through adding a dependency on sys-libs/binutils-libs. Those headers
used to be linked by binutils-config but this behavior changed lately
requesting developers to install the additional copies of all libraries
and headers instead.

Bug: https://bugs.gentoo.org/show_bug.cgi?id=561994

Package-Manager: portage-2.2.20

sys-devel/llvm/llvm-3.7.0-r1.ebuild

index 068f1b80eaae5b71ada452eb7e2c0fdc44e2281d..910b6e17e8f5eb54cc5341449d47f747bd2155e2 100644 (file)
@@ -56,6 +56,7 @@ DEPEND="${COMMON_DEPEND}
        kernel_Darwin? ( sys-libs/libcxx )
        clang? ( xml? ( virtual/pkgconfig ) )
        doc? ( dev-python/sphinx )
+       gold? ( sys-libs/binutils-libs )
        libffi? ( virtual/pkgconfig )
        lldb? ( dev-lang/swig )
        !!<dev-python/configparser-3.3.0.2