sys-libs/libcap: Revbump to adjust build system fixes
authorLars Wendler <polynomial-c@gentoo.org>
Thu, 12 Dec 2019 15:05:35 +0000 (16:05 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Thu, 12 Dec 2019 15:05:44 +0000 (16:05 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-libs/libcap/files/libcap-2.28-build-system-fixes.patch
sys-libs/libcap/files/libcap-2.28-header_location.patch [deleted file]
sys-libs/libcap/libcap-2.28-r1.ebuild [moved from sys-libs/libcap/libcap-2.28.ebuild with 97% similarity]

index 03455febadeb4282701b3eb80a88af6a18a473ea..ae0f2a36f6d55ec41e6f7c9a4d657032045d5654 100644 (file)
@@ -1,4 +1,4 @@
-From f65164072879ebb6b1fd6cc79a6b77804150bcc4 Mon Sep 17 00:00:00 2001
+From 9ce6d2ab1060c362178aba57b68bedca2d39cfe9 Mon Sep 17 00:00:00 2001
 From: Mike Frysinger <vapier@gentoo.org>
 Date: Wed, 10 Feb 2016 09:47:27 +0100
 Subject: [PATCH] build system fixes
@@ -19,21 +19,20 @@ Forward ported from libcap-2.25 to libcap-2.28
 
 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
 ---
- Make.Rules       | 28 +++++++++++++++-------------
+ Make.Rules       | 30 ++++++++++++++++++------------
  libcap/Makefile  |  7 ++++---
  pam_cap/Makefile |  8 +++++---
  progs/Makefile   |  2 +-
- 4 files changed, 25 insertions(+), 20 deletions(-)
+ 4 files changed, 28 insertions(+), 19 deletions(-)
 
 diff --git a/Make.Rules b/Make.Rules
-index ab4f17c..f97021d 100644
+index ab4f17c..1b659ea 100644
 --- a/Make.Rules
 +++ b/Make.Rules
-@@ -45,36 +45,38 @@ MINOR=28
+@@ -46,35 +46,41 @@ MINOR=28
  # Compilation specifics
  
--KERNEL_HEADERS := $(topdir)/libcap/include/uapi
+ KERNEL_HEADERS := $(topdir)/libcap/include/uapi
 -IPATH += -fPIC -I$(KERNEL_HEADERS) -I$(topdir)/libcap/include
 -
 -CC := gcc
@@ -42,10 +41,13 @@ index ab4f17c..f97021d 100644
 -BUILD_CFLAGS := $(CFLAGS) $(IPATH)
 -AR := ar
 -RANLIB := ranlib
++IPATH += -I$(KERNEL_HEADERS) -I$(topdir)/libcap/include
++
 +CC ?= gcc
 +CFLAGS ?= -O2
 +BUILD_CC ?= $(CC)
 +BUILD_CFLAGS ?= $(CFLAGS)
++BUILD_CFLAGS += $(IPATH)
 +AR ?= ar
 +RANLIB ?= ranlib
  DEBUG = -g #-DDEBUG
@@ -159,5 +161,5 @@ index 0786ad3..3abbbd9 100644
  install: all
        mkdir -p -m 0755 $(FAKEROOT)$(SBINDIR)
 -- 
-2.24.0
+2.24.1
 
diff --git a/sys-libs/libcap/files/libcap-2.28-header_location.patch b/sys-libs/libcap/files/libcap-2.28-header_location.patch
deleted file mode 100644 (file)
index 8b0678c..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-From 685fcf590a4737ddd85f085d7bccc6a9687c0023 Mon Sep 17 00:00:00 2001
-From: Lars Wendler <polynomial-c@gentoo.org>
-Date: Tue, 10 Dec 2019 11:14:57 +0100
-Subject: [PATCH] build: Fix psx_syscall.h location
-
----
- tests/libcap_psx_test.c | 2 +-
- tests/psx_test.c        | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/tests/libcap_psx_test.c b/tests/libcap_psx_test.c
-index 4b09bb0..6eebdfa 100644
---- a/tests/libcap_psx_test.c
-+++ b/tests/libcap_psx_test.c
-@@ -1,7 +1,7 @@
- #include <pthread.h>
- #include <stdio.h>
- #include <sys/capability.h>
--#include <sys/psx_syscall.h>
-+#include "../libcap/include/sys/psx_syscall.h"
- int main(int argc, char **argv) {
-     printf("hello libcap and libpsx\n");
-diff --git a/tests/psx_test.c b/tests/psx_test.c
-index 92b99a0..a3191f1 100644
---- a/tests/psx_test.c
-+++ b/tests/psx_test.c
-@@ -2,7 +2,7 @@
- #include <stdlib.h>
- #include <stdio.h>
- #include <sys/prctl.h>
--#include <sys/psx_syscall.h>
-+#include "../libcap/include/sys/psx_syscall.h"
- #include <sys/syscall.h>
- static void say_hello_expecting(const char *title, int n, int kept) {
--- 
-2.24.0
-
similarity index 97%
rename from sys-libs/libcap/libcap-2.28.ebuild
rename to sys-libs/libcap/libcap-2.28-r1.ebuild
index ab870aa7e1563a529e20dc088f4be777cc73093f..679cf0b9f262705dd5ad1f87d636029f75098190 100644 (file)
@@ -30,7 +30,6 @@ PATCHES=(
        "${FILESDIR}"/${PN}-2.28-no_perl.patch
        "${FILESDIR}"/${PN}-2.25-ignore-RAISE_SETFCAP-install-failures.patch
        "${FILESDIR}"/${PN}-2.21-include.patch
-       "${FILESDIR}"/${PN}-2.28-header_location.patch
 )
 
 src_prepare() {