dev-libs/xmlsec: cleanup old
authorAlon Bar-Lev <alonbl@gentoo.org>
Tue, 4 Jun 2019 15:28:10 +0000 (18:28 +0300)
committerAlon Bar-Lev <alonbl@gentoo.org>
Tue, 4 Jun 2019 15:28:24 +0000 (18:28 +0300)
Signed-off-by: Alon Bar-Lev <alonbl@gentoo.org>
Package-Manager: Portage-2.3.66, Repoman-2.3.11

dev-libs/xmlsec/Manifest
dev-libs/xmlsec/files/xmlsec-1.2.27-gnutls.patch [deleted file]
dev-libs/xmlsec/xmlsec-1.2.27-r1.ebuild [deleted file]

index 8a0d3bf81fbc5cd57cd060a9a30c4fee6818794e..80e759b5df256be1c7acd4ef0ac63c35a06447c4 100644 (file)
@@ -1,2 +1 @@
-DIST xmlsec1-1.2.27.tar.gz 2013651 BLAKE2B fa46a25e3aaef432134d1c98a0e7bf0aba83f2ef6d1aff3774d6d37c5f6f392d1c2c11a0fe433ee910c39b56400c96b74ab061577948622b14a1116fa1ec2947 SHA512 01f7231d7d7ac8037aecc1f922acc572cbfe0903abf5bd5879d836438c36684e23402b803d20806fff6b1cdc5ad9af114d1341b10b336f71c0bce28b4716f920
 DIST xmlsec1-1.2.28.tar.gz 1995599 BLAKE2B 5d90646d9a72024856da2638adb6d0d00d5142f8d3eaa5b12a993e2e6ae78ad49aab69822ebe331191bf1fc5b98431b85e113545aec84e2bb7d5c5add9028df0 SHA512 17fa59e4ffee5e024caa4895e8ed21d1435f14e3a37d0ed781b1dd216333ae3b6099c460efd45d4a8097d0202522150b7b0ad543b47c1596d8473b6922270480
diff --git a/dev-libs/xmlsec/files/xmlsec-1.2.27-gnutls.patch b/dev-libs/xmlsec/files/xmlsec-1.2.27-gnutls.patch
deleted file mode 100644 (file)
index 2837420..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-From 321e62add243cf8f024d6278da4c5ff030bae3b9 Mon Sep 17 00:00:00 2001
-From: Alon Bar-Lev <alon.barlev@gmail.com>
-Date: Mon, 1 Apr 2019 01:28:18 +0300
-Subject: [PATCH] gnutls: allow SHA-1 signed certificate when not in strict
- checks (#250) (#251)
-
-This is required for gnutls-3.6.x.
-
-Allow tests to use no strict checks until all certificates will be converted
-to stronger signature than SHA-1.
-
-Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
----
- src/gnutls/x509vfy.c | 3 +++
- tests/testrun.sh     | 2 +-
- 2 files changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/src/gnutls/x509vfy.c b/src/gnutls/x509vfy.c
-index a9c956a3..4c753344 100644
---- a/src/gnutls/x509vfy.c
-+++ b/src/gnutls/x509vfy.c
-@@ -295,6 +295,9 @@ xmlSecGnuTLSX509StoreVerify(xmlSecKeyDataStorePtr store,
-     if((keyInfoCtx->flags & XMLSEC_KEYINFO_FLAGS_X509DATA_SKIP_STRICT_CHECKS) != 0) {
-         flags |= GNUTLS_VERIFY_ALLOW_SIGN_RSA_MD2;
-         flags |= GNUTLS_VERIFY_ALLOW_SIGN_RSA_MD5;
-+#if GNUTLS_VERSION_NUMBER >= 0x030600
-+        flags |= GNUTLS_VERIFY_ALLOW_SIGN_WITH_SHA1;
-+#endif
-     }
-     /* We are going to build all possible cert chains and try to verify them */
-diff --git a/tests/testrun.sh b/tests/testrun.sh
-index 02484d09..ea65802b 100755
---- a/tests/testrun.sh
-+++ b/tests/testrun.sh
-@@ -59,7 +59,7 @@ if [ "z$XMLSEC_DEFAULT_CRYPTO" != "z" ] ; then
- elif [ "z$crypto" != "z" ] ; then
-     xmlsec_params="$xmlsec_params --crypto $crypto"
- fi
--xmlsec_params="$xmlsec_params --crypto-config $crypto_config"
-+xmlsec_params="$xmlsec_params --X509-skip-strict-checks --crypto-config $crypto_config"
- #
- # Setup keys config
--- 
-2.21.0
-
diff --git a/dev-libs/xmlsec/xmlsec-1.2.27-r1.ebuild b/dev-libs/xmlsec/xmlsec-1.2.27-r1.ebuild
deleted file mode 100644 (file)
index 5646081..0000000
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools
-
-DESCRIPTION="Command line tool for signing, verifying, encrypting and decrypting XML"
-HOMEPAGE="https://www.aleksey.com/xmlsec"
-SRC_URI="https://www.aleksey.com/xmlsec/download/${PN}1-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ppc ppc64 ~sparc x86"
-IUSE="doc gcrypt gnutls libressl nss +openssl static-libs test"
-REQUIRED_USE="|| ( gcrypt gnutls nss openssl )
-       gnutls? ( gcrypt )"
-
-RDEPEND=">=dev-libs/libxml2-2.7.4:=
-       >=dev-libs/libxslt-1.0.20:=
-       gcrypt? ( >=dev-libs/libgcrypt-1.4.0:0= )
-       gnutls? ( >=net-libs/gnutls-2.8.0:= )
-       nss? (
-               >=dev-libs/nspr-4.4.1:=
-               >=dev-libs/nss-3.9:=
-       )
-       openssl? (
-               !libressl? ( dev-libs/openssl:0= )
-               libressl? ( dev-libs/libressl:0= )
-       )"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig
-       test? (
-               nss? (
-                       >=dev-libs/nss-3.9[utils]
-               )
-       )"
-
-S="${WORKDIR}/${PN}1-${PV}"
-
-PATCHES=(
-       "${FILESDIR}/${P}-gnutls.patch"
-)
-
-src_prepare() {
-       default
-       # conditionally install extra documentation
-       if ! use doc ; then
-               sed -i '/^SUBDIRS/s/docs//' Makefile.am || die
-               eautoreconf
-       fi
-}
-
-src_configure() {
-       econf \
-               --enable-pkgconfig \
-               --with-html-dir=/usr/share/doc/${PF}/html \
-               $(use_enable static-libs static) \
-               $(use_with gcrypt) \
-               $(use_with gnutls) \
-               $(use_with nss) \
-               $(use_with nss nspr) \
-               $(use_with openssl) \
-               $(use_enable openssl aes)
-}
-
-src_test() {
-       emake TMPFOLDER="${T}" check
-}
-
-src_install() {
-       default
-       find "${D}" -name '*.la' -delete || die
-}