dev-python/larch: Version bump to 1.20151025
authorMatt Turner <mattst88@gentoo.org>
Thu, 11 Jul 2019 23:36:15 +0000 (16:36 -0700)
committerMatt Turner <mattst88@gentoo.org>
Fri, 12 Jul 2019 05:40:19 +0000 (22:40 -0700)
A bunch of things too:
- Port to EAPI=7
- Fix incorrect license
- HTTPS homepage
- Use tarball from cgit in SRC_URI
- Add missing [${PYTHON_USEDEP}] to dependencies
- Remove explicit ${PYTHON_DEPS} (added by python-r1)
- Import upstream test to fix test suite

Closes: https://bugs.gentoo.org/636006
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-python/larch/Manifest
dev-python/larch/files/larch-1.20151025-coverage-4.0a6-compatibility.patch [new file with mode: 0644]
dev-python/larch/larch-1.20151025.ebuild [new file with mode: 0644]

index cbae8093a865b825e7b109a99ba6ca15e961cdc2..8396cd901507adfa4969840d7f67466cb22b9c32 100644 (file)
@@ -1 +1,2 @@
+DIST larch-1.20151025.tar.gz 91990 BLAKE2B d5097fb3cd10063186dd7460b236be4564d2fef05926dad2958d200f05b44f1325fecce30d77c623cb21ae91a65af76824ebad1987a65467575ed194f3d35d5f SHA512 a0f0dd71e1558147f37e5d5f1cfd3e9b38fd925351067200376fa3644472a1c1e585d8f2f72a3d506eaea01d3dc834423d858d66d5c5fa1a746c6f4210380c33
 DIST python-larch_1.20131130.orig.tar.gz 86509 BLAKE2B f964bf4af316e010cc40513e3a767ee7d0f058ec78bfa417931ae0087e0b8d0e0c577bd99b5edfedce560fc3d21747a81e75dc1ed3527f9b054d3e8e55df7f38 SHA512 e661fa29043a5254eb3615f0eb54f6afbaf59020607bb72f621083e9f6acfbe92b1c978ce2be73336d8984a4a64ce6d0153556f0af0ca63ad53aff40f785d052
diff --git a/dev-python/larch/files/larch-1.20151025-coverage-4.0a6-compatibility.patch b/dev-python/larch/files/larch-1.20151025-coverage-4.0a6-compatibility.patch
new file mode 100644 (file)
index 0000000..6e425ae
--- /dev/null
@@ -0,0 +1,27 @@
+From ca548da9ba78ddee90779051210e3e89185e4f7d Mon Sep 17 00:00:00 2001
+From: Michel Alexandre Salim <michel@michel-slm.name>
+Date: Mon, 15 Feb 2016 23:03:42 +0700
+Subject: coverage-4.0a6 compatibility
+
+coverage 4.0a6 no longer generates .coverage file, so use -f when
+deleting .coverage to ensure deletion does not fail.
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 7818f57..362c07f 100644
+--- a/Makefile
++++ b/Makefile
+@@ -23,7 +23,7 @@ fsck-larch.1: fsck-larch.1.in fsck-larch
+ check:
+       python -m CoverageTestRunner --ignore-missing-from=without-tests
+-      rm .coverage
++      rm -f .coverage
+       ./insert-remove-test tempdir 100
+       rm -r tempdir larch.log
+       cmdtest tests
+-- 
+cgit v1.1
+
diff --git a/dev-python/larch/larch-1.20151025.ebuild b/dev-python/larch/larch-1.20151025.ebuild
new file mode 100644 (file)
index 0000000..8a496e2
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Copy-on-write B-tree data structure"
+HOMEPAGE="https://liw.fi/larch/"
+SRC_URI="http://git.liw.fi/${PN}/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+       dev-python/cliapp[${PYTHON_USEDEP}]
+       dev-python/tracing[${PYTHON_USEDEP}]
+       dev-python/ttystatus[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+BDEPEND="test? ( dev-python/coverage-test-runner[${PYTHON_USEDEP}] dev-util/cmdtest )"
+
+PATCHES=(
+       "${FILESDIR}"/${P}-coverage-4.0a6-compatibility.patch
+)
+
+src_test() {
+       addwrite /proc/self/comm
+       distutils-r1_src_test
+}
+
+python_test() {
+       emake check
+}