dev-python/setuptools: Reenable py2.7
authorMichał Górny <mgorny@gentoo.org>
Wed, 13 May 2020 11:31:21 +0000 (13:31 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 13 May 2020 11:33:16 +0000 (13:33 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/setuptools/setuptools-46.2.0.ebuild
profiles/package.mask

index ff041cbacee4e702fc93ab64e39ea319abab6760..ef030388abe83fcc6772733afd74328d31dd3373 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
 PYTHON_REQ_USE="xml(+)"
 
 inherit distutils-r1
@@ -48,8 +48,9 @@ python_prepare_all() {
        # don't run integration tests
        rm setuptools/tests/test_integration.py || die
 
-       # xpass-es for me
-       sed -i -e '/xfail.*710/d' setuptools/tests/test_archive_util.py || die
+       # xpass-es for me on py3
+       sed -e '/xfail.*710/s:(:(six.PY2, :' \
+               -i setuptools/tests/test_archive_util.py || die
 
        # avoid pointless dep on flake8
        sed -i -e 's:--flake8::' pytest.ini || die
index 97708f1d6eb8d4cf5e6b8fc3d3b4309dd07d6c54..55bb1aa73e3b79fd6f465132aab09e289a072c84 100644 (file)
@@ -834,7 +834,7 @@ www-plugins/passff
 # The new version loses Python 2 support but does not introduce any real
 # changes.  Let's mask it to reduce the noise, and hopefully try to get
 # python2_7 out of default PYTHON_TARGETS first.
->=dev-python/setuptools-45.0.0
+~dev-python/setuptools-46.1.3
 
 # Mikle Kolyada <zlogene@gentoo.org> (2020-01-13)
 # Current versioning breaks portage logic and prevents