mail-client/bower: terminal client for Notmuch (new package)
authorRalph Seichter <github@seichter.de>
Fri, 19 Oct 2018 19:56:39 +0000 (21:56 +0200)
committerMichał Górny <mgorny@gentoo.org>
Thu, 22 Nov 2018 20:27:35 +0000 (21:27 +0100)
Bower is a curses frontend for the Notmuch email system, written
in Mercury.

Bug: https://bugs.gentoo.org/405843
Package-Manager: Portage-2.3.49, Repoman-2.3.11
Signed-off-by: Ralph Seichter <gentoo@seichter.de>
Closes: https://github.com/gentoo/gentoo/pull/10180
Signed-off-by: Michał Górny <mgorny@gentoo.org>
mail-client/bower/Manifest [new file with mode: 0644]
mail-client/bower/bower-0.9.ebuild [new file with mode: 0644]
mail-client/bower/metadata.xml [new file with mode: 0644]

diff --git a/mail-client/bower/Manifest b/mail-client/bower/Manifest
new file mode 100644 (file)
index 0000000..a59a5cb
--- /dev/null
@@ -0,0 +1 @@
+DIST bower-0.9.tar.gz 256921 BLAKE2B b8bd1f179209051e5c870ceeb9efec0345a488726497775b81a87329ce6ee3b0aa0c0f6c5be8b8c2481cb9469977b549af15e1ddc302d360f3e6a79cbf560eb8 SHA512 697b5e221356cac8284da9002053e6289df25ba82f0039301643e16e40a1bda6010c9d54dd4c7a3e4c47cdbe9373713248ef2bd182df56bb035db93d089798c2
diff --git a/mail-client/bower/bower-0.9.ebuild b/mail-client/bower/bower-0.9.ebuild
new file mode 100644 (file)
index 0000000..a09adb1
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multiprocessing
+
+DESCRIPTION="A curses terminal client for the Notmuch email system"
+HOMEPAGE="https://github.com/wangp/bower"
+SRC_URI="https://github.com/wangp/bower/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="app-crypt/gpgme:=
+       >=dev-lang/mercury-11.07
+       sys-libs/ncurses:0="
+RDEPEND="app-crypt/gpgme:=
+       net-mail/notmuch
+       sys-apps/coreutils
+       sys-libs/ncurses:0="
+
+src_prepare() {
+       if has_version "sys-libs/ncurses:0[tinfo]" ; then
+               echo "MLLIBS-bower += -ltinfow" >> src/Mercury.params || die
+       fi
+       eapply_user
+}
+
+src_compile() {
+       emake PARALLEL="--jobs $(makeopts_jobs) --no-strip --very-verbose" || die
+}
+
+src_install() {
+       dobin bower
+       dodoc AUTHORS NEWS README.md bower.conf.sample
+}
diff --git a/mail-client/bower/metadata.xml b/mail-client/bower/metadata.xml
new file mode 100644 (file)
index 0000000..5560cae
--- /dev/null
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>gentoo@seichter.de</email>
+               <name>Ralph Seichter</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+       <longdescription>
+               Bower is a curses frontend for the Notmuch email system, written in Mercury.
+       </longdescription>
+       <upstream>
+               <remote-id type="github">wangp/bower</remote-id>
+       </upstream>
+</pkgmetadata>