sys-apps/onerng: switch to python-single-r1 eclass
authorConrad Kostecki <conikost@gentoo.org>
Thu, 20 Feb 2020 18:24:34 +0000 (19:24 +0100)
committerConrad Kostecki <conikost@gentoo.org>
Thu, 20 Feb 2020 18:25:01 +0000 (19:25 +0100)
Closes: https://bugs.gentoo.org/710256
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
sys-apps/onerng/onerng-3.6-r3.ebuild [new file with mode: 0644]

diff --git a/sys-apps/onerng/onerng-3.6-r3.ebuild b/sys-apps/onerng/onerng-3.6-r3.ebuild
new file mode 100644 (file)
index 0000000..3ec2cfa
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-single-r1 udev
+
+MY_P="${P/-/_}"
+
+DESCRIPTION="Software for the Open Hardware Random Number Generator called OneRNG"
+HOMEPAGE="https://www.onerng.info/"
+SRC_URI="https://github.com/OneRNG/onerng.github.io/raw/master/sw/${MY_P}.orig.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 LGPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="virtual/pkgconfig"
+
+DEPEND="virtual/udev"
+
+RDEPEND="
+       ${DEPEND}
+       ${PYTHON_DEPS}
+       app-crypt/gnupg
+       $(python_gen_cond_dep 'dev-python/python-gnupg[${PYTHON_MULTI_USEDEP}]')
+       sys-apps/rng-tools
+       sys-process/at
+"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_postinst() {
+       udev_reload
+}
+
+pkg_postrm() {
+       udev_reload
+}