dev-python/schedule: update to latest upstream release
authorStephen Arnold <nerdboy@gentoo.org>
Fri, 13 Mar 2020 03:10:16 +0000 (20:10 -0700)
committerStephen Arnold <nerdboy@gentoo.org>
Fri, 13 Mar 2020 03:10:16 +0000 (20:10 -0700)
* all python versions through nightly tested in travis
* used extensively on current keywords (both glibc and musl)

Package-Manager: Portage-2.3.67, Repoman-2.3.17
Signed-off-by: Steve Arnold <nerdboy@gentoo.org>
dev-python/schedule/Manifest
dev-python/schedule/schedule-0.4.2.ebuild [deleted file]
dev-python/schedule/schedule-0.5.0.ebuild [deleted file]
dev-python/schedule/schedule-0.6.0.ebuild [new file with mode: 0644]
dev-python/schedule/schedule-9999.ebuild [new file with mode: 0644]

index b4bda9f3e0d4d8647ecbcba2ac3349a472c842d2..cfc14fdb0addbee07e74f50edf50572794ded7c1 100644 (file)
@@ -1,2 +1 @@
-DIST schedule-0.4.2.tar.gz 10104 BLAKE2B 84089e7dde29587f4044097b85ddf4b9e3639c59c63da2268d6e2c94e94192271a6d0d65c385c9492cefac49d7abee681ebb0f56ff78965b67402306124ede40 SHA512 f088f82a0449350658028b2035c5fbc71bda4d019856fe6ab3363798e9d8d940cce603be544401ecf5f844606e5891ab560c390f5c334a825bf611e6ebfb00ac
-DIST schedule-0.5.0.tar.gz 10850 BLAKE2B b79ceb77d0149cccad4bd12c6fe8f3524a33898039319c411bf202928316d74586626d84e6921595d0c0a79f87115cbc27beb03919c4252b8468dcddf469c95a SHA512 0d89afa3c9d986c53a8c61a92bfda08e23290c6556100d63f2c647003806398b8913c4bfa75a57617aeeda73f8f2eb26490c224ab70d621873453ca5dec35b0b
+DIST schedule-0.6.0.tar.gz 21671 BLAKE2B 6076aff0c906782e554175b7e90cfca1417a31170e99009caccb5cbe318b5eb1295b24dfe1835109aec78fee53b615e170f03a7ec4470f596a9a2775c1072d5f SHA512 48424707b57cbc7ce9440e1658784347b691a013552b9969fd95dd260efa2d8ba56b41920628540fc4ebebbc3dc78e8e919b83cfddfe9a3cc3d60ece6ef0998f
diff --git a/dev-python/schedule/schedule-0.4.2.ebuild b/dev-python/schedule/schedule-0.4.2.ebuild
deleted file mode 100644 (file)
index 9e6017c..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-inherit distutils-r1
-
-DESCRIPTION="Python job scheduling for humans"
-HOMEPAGE="https://github.com/dbader/schedule"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( >=dev-python/mock-2.0.0
-               >=dev-python/pytest-3.0.3 )"
-
-python_test() {
-       py.test test_schedule.py || die
-}
diff --git a/dev-python/schedule/schedule-0.5.0.ebuild b/dev-python/schedule/schedule-0.5.0.ebuild
deleted file mode 100644 (file)
index 85fc997..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-inherit distutils-r1
-
-DESCRIPTION="Python job scheduling for humans"
-HOMEPAGE="https://github.com/dbader/schedule"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( >=dev-python/mock-2.0.0
-               >=dev-python/pytest-3.0.3 )"
-
-python_test() {
-       py.test test_schedule.py || die
-}
diff --git a/dev-python/schedule/schedule-0.6.0.ebuild b/dev-python/schedule/schedule-0.6.0.ebuild
new file mode 100644 (file)
index 0000000..24015ca
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python job scheduling for humans"
+HOMEPAGE="https://github.com/dbader/schedule"
+
+if [[ ${PV} = 9999* ]]; then
+       EGIT_REPO_URI="https://github.com/dbader/schedule"
+       EGIT_BRANCH="master"
+       inherit git-r3
+       KEYWORDS=""
+else
+       SRC_URI="https://github.com/dbader/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="${PYTHON_DEPS}"
+
+DEPEND="${PYTHON_DEPS}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+               >=dev-python/pytest-3.0.3[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+       python_export PYTHON_SITEDIR PYTHON_SCRIPTDIR
+       py.test test_schedule.py || die "Testing failed with ${EPYTHON}"
+}
diff --git a/dev-python/schedule/schedule-9999.ebuild b/dev-python/schedule/schedule-9999.ebuild
new file mode 100644 (file)
index 0000000..24015ca
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python job scheduling for humans"
+HOMEPAGE="https://github.com/dbader/schedule"
+
+if [[ ${PV} = 9999* ]]; then
+       EGIT_REPO_URI="https://github.com/dbader/schedule"
+       EGIT_BRANCH="master"
+       inherit git-r3
+       KEYWORDS=""
+else
+       SRC_URI="https://github.com/dbader/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="${PYTHON_DEPS}"
+
+DEPEND="${PYTHON_DEPS}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+               >=dev-python/pytest-3.0.3[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+       python_export PYTHON_SITEDIR PYTHON_SCRIPTDIR
+       py.test test_schedule.py || die "Testing failed with ${EPYTHON}"
+}