net-wireless/iwd: fix build w/o systemd
authorBen Kohler <bkohler@gentoo.org>
Wed, 30 Oct 2019 16:49:59 +0000 (11:49 -0500)
committerBen Kohler <bkohler@gentoo.org>
Wed, 30 Oct 2019 16:50:46 +0000 (11:50 -0500)
Explicitly set --with-systemd-networkdir since the default is to get the
value from systemd.pc which only comes from systemd

Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
net-wireless/iwd/iwd-1.0.ebuild

index e8302612e25453e291b53beec0eff953505c76c5..ba253b6098910913bab6f559369981d3039929ac 100644 (file)
@@ -123,7 +123,8 @@ src_configure() {
                --enable-external-ell \
                --enable-systemd-service \
                --with-systemd-unitdir="$(systemd_get_systemunitdir)" \
-               --with-systemd-modloaddir=$(_systemd_get_dir modulesloaddir /usr/lib/modules-load.d)
+               --with-systemd-modloaddir=$(_systemd_get_dir modulesloaddir /usr/lib/modules-load.d) \
+               --with-systemd-networkdir="$(systemd_get_utildir)/network"
 }
 
 src_install() {