net-analyzer/nagios-plugins-linux-madrisan: bump to 26
authorLouis Sautier <sbraz@gentoo.org>
Tue, 5 May 2020 18:08:03 +0000 (20:08 +0200)
committerLouis Sautier <sbraz@gentoo.org>
Tue, 5 May 2020 18:12:17 +0000 (20:12 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
net-analyzer/nagios-plugins-linux-madrisan/Manifest
net-analyzer/nagios-plugins-linux-madrisan/nagios-plugins-linux-madrisan-26.ebuild [new file with mode: 0644]

index 02102b1d690a21314771204dc19f7a983b3fb09e..439a712c11825fcaeb36643ae18271dfbecfbce0 100644 (file)
@@ -1 +1,2 @@
 DIST nagios-plugins-linux-madrisan-25.tar.xz 371712 BLAKE2B 60637426d9ced289a1acdf61c3e7c5a2b3227afb20079ef93d445057b2127d12a6c76ab5a780571ac8bdd6ac3b55de2761722236d2ed7a057ab84559d97610e9 SHA512 64961a16e24802d66c48d0c33bd63d75aba8492f38dd83a57ee2e7cb728cf6876c7869622256c4249a9e9da39b744a332df6ecad80f6039861887bb5c8d806ec
+DIST nagios-plugins-linux-madrisan-26.tar.xz 379480 BLAKE2B e30fa00c029506ffd76e9c16f409f62f00ab481894d6b35dd34470dab5f2a18b2fc18bd06ae5e6a7179ed23f36c785c9a403258b9066e5a08f6a139ab0192088 SHA512 61c523ddf7a98ae01caf543a7e38903478346ce380884a7cd2a2e592db806e73fb996675aa701e2bbf57b31ed062886daba4af70cc2875e1c296537de01c588d
diff --git a/net-analyzer/nagios-plugins-linux-madrisan/nagios-plugins-linux-madrisan-26.ebuild b/net-analyzer/nagios-plugins-linux-madrisan/nagios-plugins-linux-madrisan-26.ebuild
new file mode 100644 (file)
index 0000000..0e91fa5
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_PN="nagios-plugins-linux"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Additional and alternative Nagios plugins for Linux"
+HOMEPAGE="https://github.com/madrisan/nagios-plugins-linux"
+SRC_URI="https://github.com/madrisan/${MY_PN}/releases/download/v${PV}/${MY_P}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="curl"
+
+DEPEND="curl? ( net-misc/curl:0= )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+       default
+       # Avoid collision with net-analyzer/monitoring-plugins
+       # and net-analyzer/nagios-plugins
+       sed -ri "s/check_(load|swap|uptime|users)/&_madrisan/" plugins/Makefile.am || die
+       eautoreconf
+}
+
+src_configure() {
+       local myconf=(
+               --libexecdir="${EPREFIX}/usr/$(get_libdir)/nagios/plugins"
+               # Most options are already defaults for Gentoo
+               --disable-hardening
+               $(use_enable curl libcurl)
+       )
+       econf "${myconf[@]}"
+}
+
+src_test() {
+       emake check VERBOSE=1
+}