sys-power/thermald: version bump, 2.1
authorYixun Lan <dlan@gentoo.org>
Sun, 10 May 2020 15:22:17 +0000 (23:22 +0800)
committerYixun Lan <dlan@gentoo.org>
Sun, 10 May 2020 15:27:07 +0000 (23:27 +0800)
Closes: https://bugs.gentoo.org/720366
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Yixun Lan <dlan@gentoo.org>
sys-power/thermald/Manifest
sys-power/thermald/thermald-2.1.ebuild [new file with mode: 0644]

index a3860a3312c6a159e2f34d03b846db87c25d6317..aadd0c23ba338207ac9604ca803da694071a83aa 100644 (file)
@@ -1,2 +1,3 @@
 DIST thermald-1.9.1.tar.gz 429116 BLAKE2B 7b6105b25e89e68f82368e154b4ca2a826192d596c7427ebea3c6aa726c28b5409cf7e0f022132e2ee47423cc732a6d37b2eb05236c579e2c725820516f6993f SHA512 7c16871316fb264abad9d0182cf8b6b5c1b4c747093672e74b7db2b6aa4f322fafdf6a94bfc8a11f427f7be2ee5e5691dc6a25bb5357ce45e7afe868f89b89e1
 DIST thermald-1.9.tar.gz 427380 BLAKE2B 1954531838c0fc3677ab8f91476d5670a6b5d067d580c7c570b37e5d8d8ac408cacb218531bc8363cfd56eee9331291959ff11851550c6c782a43b19bacca01a SHA512 71fa6e9fc2f55623ed0acdb65f9699d5ea2c89c4092546a73d53ac3ea3ca0a5c60f3360c8bef0af9daeeecfe9a20411d9e4d25bc1d89349cfe83ebb03ba387a8
+DIST thermald-2.1.tar.gz 435310 BLAKE2B 7a5b67c2f8cb56276427188a91cc0d0c5cc7975ea847abe6eddc41b5dba77f908bc1ab97234568c65b2bcbb3bfff7881412cef2f8aa422139c64d5fb089a6511 SHA512 407d743d2799f84cd178e17ef694f0825f03db4ce80a47df95826bc26a9f142b80295905707fcba41bd5268d411a03478cd9d432545f9e2f1394d7d61539e169
diff --git a/sys-power/thermald/thermald-2.1.ebuild b/sys-power/thermald/thermald-2.1.ebuild
new file mode 100644 (file)
index 0000000..b551961
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic out-of-source systemd
+
+DESCRIPTION="Thermal daemon for Intel architectures"
+HOMEPAGE="https://01.org/linux-thermal-daemon"
+SRC_URI="https://github.com/01org/thermal_daemon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+       dev-libs/dbus-glib:=
+       dev-libs/glib:=
+       dev-libs/libxml2:=
+       sys-apps/dbus:="
+DEPEND="${RDEPEND}
+       dev-util/glib-utils"
+
+S=${WORKDIR}/thermal_daemon-${PV}
+DOCS=( thermal_daemon_usage.txt README.txt )
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+my_src_configure() {
+       # bug 618948
+       append-cxxflags -std=c++14
+
+       ECONF_SOURCE="${S}" econf \
+               --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+}
+
+my_src_install_all() {
+       einstalldocs
+
+       rm -rf "${ED}"/etc/init || die
+       doinitd "${FILESDIR}"/thermald
+}