x11-misc/mugshot: drop old version
authorConrad Kostecki <conrad@kostecki.com>
Wed, 15 Aug 2018 21:23:03 +0000 (23:23 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Sun, 19 Aug 2018 22:50:43 +0000 (00:50 +0200)
Bug: https://bugs.gentoo.org/663740
Package-Manager: Portage-2.3.45, Repoman-2.3.10

x11-misc/mugshot/Manifest
x11-misc/mugshot/files/fix_env_spawn_args.patch [deleted file]
x11-misc/mugshot/files/missing_default_face.patch [deleted file]
x11-misc/mugshot/files/use_office_phone.patch [deleted file]
x11-misc/mugshot/metadata.xml
x11-misc/mugshot/mugshot-0.4.0.ebuild [deleted file]

index 8d4365f855cb910f5fb289e99df500a4ee1229ef..e48b73d1ea60ca74b37dd02ee2c241ea18af9842 100644 (file)
@@ -1,2 +1 @@
-DIST mugshot-0.4.0.tar.gz 126101 BLAKE2B be0d84fd09a1ff6477d32a77d979b1606597b2ca38524b9cc65c254dd9d5d43697123b10d2b836c1193a9ba0f3dadebb15d1fe89ab7fb1743cc7b4d177ace65d SHA512 5936ec3def5a70db21f9bcc7fce873ce374f8df0795fb944593f398704dcba8c81be30393603e1753e176da87f4a6fd8a3218de2aeb7f33ea6018735ce1b2c09
 DIST mugshot-0.4.1.tar.gz 121660 BLAKE2B ce0c0d4b76184f35e4ba5204b984393412924c0288b09fe51ec0e6635b1556e24ed98ce4a893ae57f25810bb39ce035fb40b6990e1b6516406cb0f670acdbac0 SHA512 f7790b3f80fc98d9b19e9b9dd74eafc41ae7598e38f70e148502056b4bd375922271cc72cf4664280f1449b2f5e1d89052ecc5d37c6dc453041e5312f736bbbe
diff --git a/x11-misc/mugshot/files/fix_env_spawn_args.patch b/x11-misc/mugshot/files/fix_env_spawn_args.patch
deleted file mode 100644 (file)
index bb24418..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
---- a/mugshot_lib/SudoDialog.py        2018-04-12 00:23:21.000000000 +0200
-+++ b/mugshot_lib/SudoDialog.py        2018-06-22 22:21:10.876589365 +0200
-@@ -48,7 +48,7 @@
-             return False
-     # Check for LANG requirements
--    child = env_spawn('sudo -v', 1)
-+    child = env_spawn('sudo', ['-v'], 1)
-     if child.expect([".*ssword.*", "Sorry",
-                      pexpect.EOF,
-                      pexpect.TIMEOUT]) == 3:
-@@ -57,7 +57,7 @@
-     child.close()
-     # Check for sudo rights
--    child = env_spawn('sudo -v', 1)
-+    child = env_spawn('sudo', ['-v'], 1)
-     try:
-         index = child.expect([".*ssword.*", "Sorry",
-                               pexpect.EOF, pexpect.TIMEOUT])
-@@ -76,14 +76,14 @@
-     return False
--def env_spawn(command, timeout):
-+def env_spawn(command, args, timeout):
-     """Use pexpect.spawn, adapt for timeout and env requirements."""
-     env = os.environ
-     env["LANG"] = "C"
-     if use_env:
--        child = pexpect.spawn(command, env)
-+        child = pexpect.spawn(command, args, env)
-     else:
--        child = pexpect.spawn(command)
-+        child = pexpect.spawn(command, args)
-     child.timeout = timeout
-     return child
-@@ -304,7 +304,7 @@
-         Return True if successful.
-         '''
-         # Set the pexpect variables and spawn the process.
--        child = env_spawn('sudo /bin/true', 1)
-+        child = env_spawn('sudo', ['/bin/true'], 1)
-         try:
-             # Check for password prompt or program exit.
-             child.expect([".*ssword.*", pexpect.EOF])
diff --git a/x11-misc/mugshot/files/missing_default_face.patch b/x11-misc/mugshot/files/missing_default_face.patch
deleted file mode 100644 (file)
index 0d25fb6..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/mugshot/MugshotWindow.py 2018-04-12 00:23:21.000000000 +0200
-+++ b/mugshot/MugshotWindow.py 2018-06-22 22:27:05.515588012 +0200
-@@ -257,10 +257,11 @@
-             logger.debug('Found profile image: %s' % str(image))
-             if os.path.isfile(face):
--                if os.path.samefile(image, face):
--                    self.updated_image = face
--                else:
--                    self.updated_image = None
-+                if os.path.exists(image):
-+                    if os.path.samefile(image, face):
-+                        self.updated_image = face
-+                    else:
-+                        self.updated_image = None
-                 self.set_user_image(face)
-             elif os.path.isfile(image):
-                 self.updated_image = image
diff --git a/x11-misc/mugshot/files/use_office_phone.patch b/x11-misc/mugshot/files/use_office_phone.patch
deleted file mode 100644 (file)
index bea3f7c..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/mugshot/MugshotWindow.py 2018-06-22 22:33:03.980586645 +0200
-+++ b/mugshot/MugshotWindow.py 2018-06-22 22:41:44.120584661 +0200
-@@ -614,10 +614,14 @@
-         logger.debug('Updating Office Phone...')
-         command = "%s -w \"%s\" %s" % (chfn, office_phone, username)
-+        command2 = "%s -o \"%s\" %s" % (chfn, office_phone, username)
-         if self.process_terminal_password(command, password):
-             self.office_phone = office_phone
-         else:
--            success = False
-+            if self.process_terminal_password(command2, password):
-+                self.office_phone = office_phone
-+            else:
-+                success = False
-         return (success, response)
index 9e143660d3182650ef365cb4406b34fca619fbc6..70aef0f5e7974eaec345458db67585dc2291a8d1 100644 (file)
@@ -17,7 +17,6 @@
        <use>
                <flag name="gnome">Add support for <pkg>gnome-base/gnome-control-center</pkg></flag>
                <flag name="libreoffice">Add support for <pkg>app-office/libreoffice</pkg> and <pkg>app-office/libreoffice-bin</pkg></flag>
-               <flag name="pidgin">Add support for setting the avatar in <pkg>net-im/pidgin</pkg> </flag>
                <flag name="webcam">Add support for setting a profile photo in <pkg>media-video/cheese</pkg></flag>
        </use>
        <upstream>
diff --git a/x11-misc/mugshot/mugshot-0.4.0.ebuild b/x11-misc/mugshot/mugshot-0.4.0.ebuild
deleted file mode 100644 (file)
index 23ceab5..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 eapi7-ver gnome2-utils
-
-DESCRIPTION="A lightweight user-configuration application"
-HOMEPAGE="https://launchpad.net/mugshot"
-SRC_URI="https://launchpad.net/${PN}/$(ver_cut 1-2)/${PV}/+download/${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="gnome libreoffice pidgin webcam"
-
-RDEPEND="dev-libs/gobject-introspection
-       dev-python/dbus-python[${PYTHON_USEDEP}]
-       dev-python/pexpect[${PYTHON_USEDEP}]
-       dev-python/pycairo[${PYTHON_USEDEP}]
-       dev-python/pygobject:3[${PYTHON_USEDEP}]
-       sys-apps/accountsservice
-       x11-libs/gtk+:3
-       gnome? ( gnome-base/gnome-control-center )
-       libreoffice? ( || ( app-office/libreoffice-bin app-office/libreoffice ) )
-       pidgin? ( net-im/pidgin[${PYTHON_USEDEP}] )
-       webcam? ( media-libs/gstreamer:1.0
-               media-libs/gst-plugins-good:1.0
-               gnome? ( media-libs/clutter-gtk[introspection]
-                       media-video/cheese[introspection] ) )"
-
-DEPEND="dev-python/python-distutils-extra[${PYTHON_USEDEP}]
-       dev-util/intltool
-       ${RDEPEND}"
-
-PATCHES=(
-       # https://bugs.launchpad.net/ubuntu/+source/mugshot/+bug/1443283
-       "${FILESDIR}/fix_env_spawn_args.patch"
-       # Both patches are taken from Arch Linux
-       "${FILESDIR}/missing_default_face.patch"
-       "${FILESDIR}/use_office_phone.patch"
-)
-
-pkg_postinst() {
-       gnome2_schemas_update
-       gnome2_icon_cache_update
-}
-
-pkg_postrm() {
-       gnome2_schemas_update
-       gnome2_icon_cache_update
-}