kde-misc/kio-gdrive: Fix USE=-handbook, add missing RDEPEND
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 19 Oct 2017 19:00:29 +0000 (21:00 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 19 Oct 2017 19:02:49 +0000 (21:02 +0200)
Reported-by: Valeriy Malov <jazzvoid@gmail.com>
Gentoo-bug: 633810
Package-Manager: Portage-2.3.11, Repoman-2.3.3

kde-misc/kio-gdrive/files/kio-gdrive-1.2.1-doctools.patch [new file with mode: 0644]
kde-misc/kio-gdrive/kio-gdrive-1.2.1-r1.ebuild [new file with mode: 0644]

diff --git a/kde-misc/kio-gdrive/files/kio-gdrive-1.2.1-doctools.patch b/kde-misc/kio-gdrive/files/kio-gdrive-1.2.1-doctools.patch
new file mode 100644 (file)
index 0000000..7ddcf14
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt   2017-09-30 17:29:04.000000000 +0200
++++ b/CMakeLists.txt   2017-10-19 20:51:03.198871146 +0200
+@@ -80,5 +80,6 @@
+ find_package(KF5I18n CONFIG REQUIRED)
+ ki18n_install(po)
+-find_package(KF5DocTools CONFIG REQUIRED)
+-kdoctools_install(po)
++if(KF5DocTools_FOUND)
++    kdoctools_install(po)
++endif()
diff --git a/kde-misc/kio-gdrive/kio-gdrive-1.2.1-r1.ebuild b/kde-misc/kio-gdrive/kio-gdrive-1.2.1-r1.ebuild
new file mode 100644 (file)
index 0000000..8f56003
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+inherit kde5
+
+DESCRIPTION="KIO Slave for Google Drive service"
+HOMEPAGE="https://phabricator.kde.org/project/profile/72/"
+
+if [[ ${KDE_BUILD_TYPE} != live ]] ; then
+       SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+IUSE="+kaccounts"
+
+COMMON_DEPEND="
+       $(add_frameworks_dep kcoreaddons)
+       $(add_frameworks_dep ki18n)
+       $(add_frameworks_dep kio)
+       $(add_frameworks_dep knotifications)
+       $(add_kdeapps_dep libkgapi)
+       $(add_qt_dep qtwidgets)
+       kaccounts? ( $(add_kdeapps_dep kaccounts-integration) )
+       !kaccounts? ( dev-libs/qtkeychain:=[qt5(+)] )
+"
+DEPEND="${COMMON_DEPEND}
+       $(add_qt_dep qtgui)
+       $(add_qt_dep qtnetwork)
+       dev-util/intltool
+"
+RDEPEND="${COMMON_DEPEND}
+       kaccounts? ( $(add_kdeapps_dep kaccounts-providers) )
+"
+
+DOCS=( README.md )
+
+PATCHES=( "${FILESDIR}/${P}-doctools.patch" )
+
+src_configure() {
+       local mycmakeargs=(
+               $(cmake-utils_use_find_package kaccounts KAccounts)
+       )
+       kde5_src_configure
+}