dev-python/nose: Flatten twisted dep
authorMichał Górny <mgorny@gentoo.org>
Thu, 26 Mar 2020 17:29:24 +0000 (18:29 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 26 Mar 2020 17:35:49 +0000 (18:35 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/nose/nose-1.3.7-r3.ebuild
dev-python/nose/nose-1.3.7-r4.ebuild

index 9543143b1bccf1d62ef3d8df27b9d2a493ff33c4..a52cccd978fe3d3eddb0ff3a0f1598d778e9fd88 100644 (file)
@@ -29,9 +29,11 @@ RDEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]"
 DEPEND="${RDEPEND}
        doc? ( >=dev-python/sphinx-0.6[${PYTHON_USEDEP}] )
-       test? ( || ( $(python_gen_cond_dep 'dev-python/twisted[${PYTHON_USEDEP}]' python2_7 python3_{5,6})
-                       $(python_gen_cond_dep 'dev-python/twisted-core[${PYTHON_USEDEP}]' python2_7)
-                ) )"
+       test? (
+               $(python_gen_cond_dep '
+                       dev-python/twisted[${PYTHON_USEDEP}]
+               ' python2_7 python3_{6,7})
+       )"
 
 PATCHES=(
        "${FILESDIR}"/${P}-python-3.5-backport.patch
index 431ecc06eef7bf25849ea40a82b0355b98c68e49..e09fa46958b6d13b6fb4876876d050264b949637 100644 (file)
@@ -35,9 +35,12 @@ RDEPEND="
 DEPEND="${RDEPEND}
        doc? ( >=dev-python/sphinx-0.6[$(python_gen_usedep 'python2*')] )
        test? (
-               $(python_gen_cond_dep 'dev-python/coverage[${PYTHON_USEDEP}]' \
-                       "${COVERAGE_IMPLS[@]}")
-               $(python_gen_cond_dep 'dev-python/twisted[${PYTHON_USEDEP}]' python2_7 python3_{5,6})
+               $(python_gen_cond_dep '
+                       dev-python/coverage[${PYTHON_USEDEP}]
+               ' "${COVERAGE_IMPLS[@]}")
+               $(python_gen_cond_dep '
+                       dev-python/twisted[${PYTHON_USEDEP}]
+               ' python2_7 python3_{6,7})
        )"
 
 PATCHES=(